Bug 156138 - IDE hangs on start debugger
IDE hangs on start debugger
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Debugger
6.x
All Windows XP
: P2 (vote)
: 6.x
Assigned To: Egor Ushakov
issues@cnd
65fixes3-fixed
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-29 19:40 UTC by Alexander Pepin
Modified: 2009-06-25 10:59 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
java stack (16.85 KB, text/plain)
2008-12-29 19:41 UTC, Alexander Pepin
Details
gdb log (2.93 KB, text/plain)
2008-12-29 19:46 UTC, Alexander Pepin
Details
Patch for release65_fixes (44.25 KB, text/plain)
2009-02-05 13:45 UTC, Egor Ushakov
Details
patch2 (2.80 KB, text/plain)
2009-02-05 17:45 UTC, Egor Ushakov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Pepin 2008-12-29 19:40:30 UTC
Despite I filed this issue against GDB it seems to me that the root cause could be in another component.

Steps to reproduce:
- create Quote sample
- set function BP in 'main'
- set line BP's on "switch" operator in all class methods where it's used
memory.cc:48
memory.cc:62
memory.cc:78

cpu.cc:48
cpu.cc:62
cpu.cc:75

disk.cc:55
disk.cc:68

- start debugger
Result: Debugger is trying to start. IDE hangs.
Comment 1 Alexander Pepin 2008-12-29 19:41:16 UTC
Created attachment 75352 [details]
java stack
Comment 2 Alexander Pepin 2008-12-29 19:46:25 UTC
Created attachment 75353 [details]
gdb log
Comment 3 Alexander Pepin 2008-12-29 19:48:24 UTC
after some time (about a minute or even more) ide resumes but debugger gets into "unknown" state.
Comment 4 Alexander Pepin 2009-02-04 16:50:33 UTC
Due to user's complaint the issue is nominated to patch 3 candidate
Comment 5 Egor Ushakov 2009-02-04 16:57:36 UTC
It looks like under gdb output can block input somehow.
Fixed in:
http://hg.netbeans.org/main/rev/a8f5e6fb60a9
Comment 6 Egor Ushakov 2009-02-05 13:44:59 UTC
I will attach patch to integrate this fix into patch3 branch
Comment 7 Egor Ushakov 2009-02-05 13:45:37 UTC
Created attachment 76602 [details]
Patch for release65_fixes
Comment 8 Egor Ushakov 2009-02-05 17:45:25 UTC
Created attachment 76626 [details]
patch2
Comment 9 Egor Ushakov 2009-02-05 17:46:08 UTC
both patches need to be applied
Comment 10 Alexander Pepin 2009-02-26 14:11:25 UTC
verified in build 200902260201
Comment 12 Egor Ushakov 2009-03-04 10:05:43 UTC
extra fix:
http://hg.netbeans.org/release65_fixes/rev/d2d3261d3874
Comment 13 Alexander Pepin 2009-03-04 13:05:07 UTC
extra fix works fine


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo