Bug 156016 - org.netbeans.modules.parsing classes are loaded on 1st and 2nd NetBeans startup
org.netbeans.modules.parsing classes are loaded on 1st and 2nd NetBeans startup
Status: RESOLVED WONTFIX
Product: editor
Classification: Unclassified
Component: Parsing & Indexing
6.x
PC Windows XP
: P4 (vote)
: 6.x
Assigned To: Tomas Zezula
issues@editor
http://wiki.netbeans.org/FitnessViaWh...
: PERFORMANCE, REGRESSION, TEST
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-23 18:57 UTC by Alexander Kouznetsov
Modified: 2016-07-07 07:26 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Stacktraces (49.20 KB, text/plain)
2008-12-23 18:58 UTC, Alexander Kouznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Kouznetsov 2008-12-23 18:57:41 UTC
Performance test reports there is regression in 1st and 2nd NetBeans startup which is caused by the loading of following
classes:

org.netbeans.modules.parsing.api.Task
org.netbeans.modules.parsing.impl.CurrentDocumentScheduler
org.netbeans.modules.parsing.impl.CurrentEditorTaskScheduler
org.netbeans.modules.parsing.impl.CurrentEditorTaskScheduler$AListener
org.netbeans.modules.parsing.impl.CursorSensitiveScheduler
org.netbeans.modules.parsing.impl.FileObjectsTaskScheduler
org.netbeans.modules.parsing.impl.Installer
org.netbeans.modules.parsing.impl.Schedulers
org.netbeans.modules.parsing.impl.SelectedNodesScheduler
org.netbeans.modules.parsing.impl.SelectedNodesScheduler$AListener
org.netbeans.modules.parsing.impl.TaskProcessor
org.netbeans.modules.parsing.impl.TaskProcessor$CompilationJob
org.netbeans.modules.parsing.impl.TaskProcessor$CurrentRequestReference
org.netbeans.modules.parsing.impl.TaskProcessor$DeferredTask
org.netbeans.modules.parsing.impl.TaskProcessor$InternalLock
org.netbeans.modules.parsing.impl.TaskProcessor$Request
org.netbeans.modules.parsing.impl.TaskProcessor$RequestPriorityComparator
org.netbeans.modules.parsing.impl.TaskProcessor$WorkerThreadFactory
org.netbeans.modules.parsing.impl.Utilities
org.netbeans.modules.parsing.impl.Utilities$IndexingStatus
org.netbeans.modules.parsing.spi.ParserResultTask
org.netbeans.modules.parsing.spi.Scheduler
org.netbeans.modules.parsing.spi.SchedulerTask

Please don't load these classes unless they're really necessary.

Comment from jtulach:
> Looks like this is being triggered without any open project by java.source module:
> 
> org.netbeans.modules.java.source.usages.RepositoryUpdater.getDefault(RepositoryUpdater.java:3641)
> org.netbeans.modules.java.source.JBrowseModule$1$1.run(JBrowseModule.java:86)
> 
> This shall be prevented. Report a bug for java.source to prevent this initialization until at least one Java file is
accessed.

More information is available via the URL specified.
Comment 1 Alexander Kouznetsov 2008-12-23 18:58:24 UTC
Created attachment 75278 [details]
Stacktraces
Comment 2 Jan Lahoda 2009-01-07 13:36:34 UTC
Should not happen when ergonomics is enabled. May be fixed by the future indexing api.
Comment 3 Alexander Kouznetsov 2009-01-14 14:20:21 UTC
The following class was not loaded during 1st and 2nd NetBeans startup with 090111 build:

org.netbeans.modules.parsing.impl.FileObjectsTaskScheduler 
Comment 4 Rastislav Komara 2009-02-03 10:53:40 UTC
Overtake.
Comment 5 Vitezslav Stejskal 2009-06-02 15:58:58 UTC
Can we please retest this in the current dev builds? IMO this has been improved and the classes should no longer be
loaded. Thanks
Comment 6 Oleg Khokhlov 2009-06-10 17:40:43 UTC
build 20090608
    org.netbeans.modules.parsing.impl.CurrentDocumentScheduler
    org.netbeans.modules.parsing.impl.CurrentEditorTaskScheduler
    org.netbeans.modules.parsing.impl.CurrentEditorTaskScheduler$AListener
    org.netbeans.modules.parsing.impl.CursorSensitiveScheduler
    org.netbeans.modules.parsing.impl.Installer
    org.netbeans.modules.parsing.impl.Schedulers
    org.netbeans.modules.parsing.impl.SelectedNodesScheduler
    org.netbeans.modules.parsing.impl.SelectedNodesScheduler$AListener
    org.netbeans.modules.parsing.impl.indexing.PathRegistry
    org.netbeans.modules.parsing.impl.indexing.PathRegistry$Listener
    org.netbeans.modules.parsing.impl.indexing.PathRegistryListener
    org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater
    org.netbeans.modules.parsing.impl.indexing.RepositoryUpdater$State
    org.netbeans.modules.parsing.impl.indexing.friendapi.IndexingActivityInterceptor
    org.netbeans.modules.parsing.spi.Scheduler
Comment 7 Martin Balin 2016-07-07 07:26:40 UTC
This old bug may not be relevant anymore. If you can still reproduce it in 8.2 development builds please reopen this issue.

Thanks for your cooperation,
NetBeans IDE 8.2 Release Boss


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo