Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 156013 - Getters/setters for static fields
Getters/setters for static fields
Status: VERIFIED FIXED
Product: php
Classification: Unclassified
Component: Editor
6.x
All All
: P2 with 2 votes (vote)
: 7.4
Assigned To: Ondrej Brejla
issues@php
:
: 151615 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-23 18:01 UTC by Mikhail Matveev
Modified: 2013-07-25 15:59 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Mikhail Matveev 2008-12-23 18:01:08 UTC
It would be nice to have possibility to generate (Alt+Ins) getters/setters for static fields (same way as for usual fields).
Comment 1 Tomasz Slota 2010-02-10 08:45:43 UTC
reassigning to default owner
Comment 2 Filip Zamboj 2010-09-15 12:28:00 UTC
batch reassigning
Comment 3 Ondrej Brejla 2011-08-15 09:44:57 UTC
*** Bug 151615 has been marked as a duplicate of this bug. ***
Comment 4 stso 2012-06-17 19:50:08 UTC
Needed this multiple times too!
Comment 5 Ondrej Brejla 2012-12-19 15:54:27 UTC
Good idea.
Comment 6 Ondrej Brejla 2013-01-03 10:31:27 UTC
Fixed on a branch as a PHP 7.4 feature in web-main #9312dd5fbd28
Comment 7 Quality Engineering 2013-01-30 03:40:27 UTC
Integrated into 'main-golden', will be available in build *201301300001* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/9312dd5fbd28
User: Ondrej Brejla <obrejla@netbeans.org>
Log: #156013 - Getters/setters for static fields
Comment 8 mmolda 2013-07-25 15:59:25 UTC
Verified, available in 7.4.

Product Version: NetBeans IDE 7.4 Beta (Build 201306141844)
Java: 1.7.0_25; Java HotSpot(TM) 64-Bit Server VM 23.25-b01
Runtime: Java(TM) SE Runtime Environment 1.7.0_25-b15
System: Windows 7 version 6.1 running on amd64; Cp1250; en_US (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo