Bug 156010 - java.sql.SQLException: ORA-00942: table or view does not exist
java.sql.SQLException: ORA-00942: table or view does not exist
Status: RESOLVED WORKSFORME
Product: db
Classification: Unclassified
Component: DB schema
6.x
All Windows XP
: P3 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@db
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-23 16:17 UTC by pecas
Modified: 2010-01-06 03:42 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (1.35 KB, text/plain)
2008-12-23 16:17 UTC, pecas
Details
stacktrace (1.35 KB, text/plain)
2008-12-31 15:41 UTC, pecas
Details
stacktrace (1.83 KB, text/plain)
2009-03-25 14:55 UTC, misterm
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pecas 2008-12-23 16:17:35 UTC
Build: NetBeans IDE 6.5 Beta (Build 200808111757)
VM: Java HotSpot(TM) Client VM, 1.5.0_10-b03, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_10-b03
OS: Windows XP, 5.1, x86

User Comments:
pecas: I need recapture schema from DataBase

joostnufan: refresh DATABASE Schema

pecas: I need recapture schema from DataBase



Stacktrace: 
java.sql.SQLException: ORA-00942: table or view does not exist

        at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:112)
        at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:331)
        at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:288)
        at oracle.jdbc.driver.T4C8Oall.receive(T4C8Oall.java:743)
        at oracle.jdbc.driver.T4CStatement.doOall8(T4CStatement.java:207)
        at oracle.jdbc.driver.T4CStatement.executeForDescribe(T4CStatement.java:790)
Comment 1 pecas 2008-12-23 16:17:42 UTC
Created attachment 75277 [details]
stacktrace
Comment 2 pecas 2008-12-31 15:41:45 UTC
Build: NetBeans IDE 6.5 Beta (Build 200808111757)
VM: Java HotSpot(TM) Client VM, 1.5.0_10-b03, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_10-b03
OS: Windows XP, 5.1, x86

User Comments: 


Stacktrace: 
java.sql.SQLException: ORA-00942: table or view does not exist

        at oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:112)
        at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:331)
        at oracle.jdbc.driver.T4CTTIoer.processError(T4CTTIoer.java:288)
        at oracle.jdbc.driver.T4C8Oall.receive(T4C8Oall.java:743)
        at oracle.jdbc.driver.T4CStatement.doOall8(T4CStatement.java:207)
        at oracle.jdbc.driver.T4CStatement.executeForDescribe(T4CStatement.java:790)
Comment 3 pecas 2008-12-31 15:41:51 UTC
Created attachment 75385 [details]
stacktrace
Comment 4 Jiri Rechtacek 2009-02-10 15:21:48 UTC
Reassigned to new owner.
Comment 5 Jiri Rechtacek 2009-02-24 13:28:59 UTC
Is it still a problem? Could you attach steps to reproducing this problem? Thanks
Comment 6 misterm 2009-03-25 14:55:20 UTC
Build: NetBeans IDE 6.5 (Build 200811100001)
VM: Java HotSpot(TM) Client VM, 10.0-b19, Java(TM) SE Runtime Environment, 1.6.0_04-b12
OS: Windows XP, 5.1, x86

User Comments: 
Error while expanding node. Prevents any info about table from being displayed

Stacktrace: 
org.netbeans.api.db.explorer.DatabaseException: java.sql.SQLException: ORA-01031: insufficient privileges

        at org.netbeans.modules.db.explorer.infos.TableNodeInfo.initChildren(TableNodeInfo.java:172)
        at org.netbeans.modules.db.explorer.infos.TableNodeInfo.initChildren(TableNodeInfo.java:78)
        at org.netbeans.modules.db.explorer.infos.DatabaseNodeInfo.loadChildren(DatabaseNodeInfo.java:765)
        at org.netbeans.modules.db.explorer.infos.DatabaseNodeInfo.getChildren(DatabaseNodeInfo.java:753)
        at org.netbeans.modules.db.explorer.nodes.DatabaseNode$DatabaseNodeChildFactory.createKeys(DatabaseNode.java:382)
        at org.openide.nodes.AsynchChildren.run(AsynchChildren.java:147)
Comment 7 misterm 2009-03-25 14:55:24 UTC
Created attachment 78827 [details]
stacktrace
Comment 8 misterm 2009-03-25 14:58:54 UTC
Steps to reproduce using Oracle:

1. Create any number of tables for user A;
2. Create public synonyms for them and grant select, update, delete and insert permissions to user B, a regular user;
3. Connect in NB using B;
4. Expand the node for the tables created in step 1.
Comment 9 Jiri Rechtacek 2010-01-06 03:42:27 UTC
The bug seems to be obsolete.
@misterm: your case is an another than the original. Please, file it again with NB6.8 in best. Thanks


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo