Bug 155991 - Unable to use ruby support after downloading it from UC
Unable to use ruby support after downloading it from UC
Status: RESOLVED FIXED
Product: platform
Classification: Unclassified
Component: Autoupdate
6.x
PC Linux
: P3 (vote)
: 6.x
Assigned To: Jaroslav Tulach
issues@platform
: ERGONOMICS
: 157259 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-23 11:40 UTC by Tomas Danek
Modified: 2009-02-19 20:23 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Test that simulates the problem (3.67 KB, patch)
2009-02-03 11:28 UTC, Jaroslav Tulach
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Danek 2008-12-23 11:40:01 UTC
Product Version: NetBeans IDE Dev (Build 200812230201)
Java: 1.6.0_10-beta; Java HotSpot(TM) Client VM 11.0-b11
System: Linux version 2.6.27-9-generic running on i386; UTF-8; en_US (nb)
Userdir: /tmp/ud
-------------
- unzipped j2se version of IDE
- installed ruby support from UC (2 kit modules)
- tried to create ruby project -> invoked new project wizard, but step 2 resulted in:
"request functionality not found"

BTW.seems to me like even the label is wrong, there should be "requested" instead of "request"?!
Comment 1 Jaromir Uhrik 2009-01-06 09:40:13 UTC
I meet the same behavior when installed C/C++ support in the latest build from 2009/Jan/06. Notice that the C/C++ is
then offered for installation in Plugin Manager (it is the same for Ruby and Rails).
Comment 2 Jaroslav Tulach 2009-01-06 12:23:35 UTC
The issue is gone, due to the fact that Java SE distribution does not contain any Ergonomics anymore. Anyway, I'll try 
to investigate what is wrong.
Comment 3 Quality Engineering 2009-01-07 16:57:44 UTC
Integrated into 'main-golden', will be available in build *200901071401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/16c516c39ab9
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: Wrong label identified as part of problem in #155991 report
Comment 4 Jaroslav Tulach 2009-02-03 09:57:59 UTC
This problem remains in java all distribution and needs to be fixed.
Comment 5 Jaroslav Tulach 2009-02-03 10:00:19 UTC
*** Issue 157259 has been marked as a duplicate of this issue. ***
Comment 6 Jaroslav Tulach 2009-02-03 11:27:33 UTC
The cause is somewhere in updater. It is incapable to remove _hidden file from userdir when installing into shared 
location.
Comment 7 Jaroslav Tulach 2009-02-03 11:28:51 UTC
Created attachment 76507 [details]
Test that simulates the problem
Comment 8 Jaroslav Tulach 2009-02-03 12:30:01 UTC
Basically fixed in ergonomics#bd23ab7c5bc6
Still there remains some problem with installed, but disabled modules.
Comment 9 Jaroslav Tulach 2009-02-03 13:11:05 UTC
ergonomics#80d20addcc98
Comment 10 Quality Engineering 2009-02-04 21:21:37 UTC
Integrated into 'main-golden', will be available in build *200902041526* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/bd23ab7c5bc6
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #155991: Removing config/Modules/*.xml_hidden file(s) for installed module(s)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo