Bug 155977 - NullPointerException at org.netbeans.modules.db.metadata.model.jdbc.JDBCTable.createJDBCIndexColumn
NullPointerException at org.netbeans.modules.db.metadata.model.jdbc.JDBCTable...
Status: RESOLVED FIXED
Product: db
Classification: Unclassified
Component: Code
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Jiri Rechtacek
issues@db
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
: 171089 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-23 09:21 UTC by aliyang
Modified: 2009-10-05 20:25 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (2.27 KB, text/plain)
2008-12-23 09:22 UTC, aliyang
Details
stacktrace (2.27 KB, text/plain)
2009-03-11 13:28 UTC, vlad_konov
Details
stacktrace (2.27 KB, text/plain)
2009-03-16 18:31 UTC, vlad_konov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description aliyang 2008-12-23 09:21:08 UTC
Build: NetBeans IDE Dev (Build 200812221122)
VM: Java HotSpot(TM) Client VM, 11.0-b16, Java(TM) SE Runtime Environment, 1.6.0_11-b03
OS: Windows XP, 5.1, x86

Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.db.metadata.model.jdbc.JDBCTable.createJDBCIndexColumn(JDBCTable.java:227)
        at org.netbeans.modules.db.metadata.model.jdbc.JDBCTable.createIndexes(JDBCTable.java:197)
        at org.netbeans.modules.db.metadata.model.jdbc.JDBCTable.initIndexes(JDBCTable.java:374)
        at org.netbeans.modules.db.metadata.model.jdbc.JDBCTable.getIndexes(JDBCTable.java:123)
        at org.netbeans.modules.db.metadata.model.api.Table.getIndexes(Table.java:100)
        at org.netbeans.modules.db.explorer.node.ColumnNode$1.run(ColumnNode.java:144)
Comment 1 aliyang 2008-12-23 09:22:55 UTC
Created attachment 75262 [details]
stacktrace
Comment 2 Jiri Rechtacek 2009-02-10 15:38:03 UTC
Reassigned to new owner.
Comment 3 Exceptions Reporter 2009-02-20 23:07:45 UTC
This issue has already 5 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=144635
Comment 4 vlad_konov 2009-03-11 13:28:08 UTC
Build: NetBeans IDE Dev (Build 200902231810)
VM: Java HotSpot(TM) Client VM, 10.0-b23, Java(TM) SE Runtime Environment, 1.6.0_07-b06
OS: Windows XP, 5.1, x86

User Comments: 
Trying to expand fields list for a table in "services" window.

Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.db.metadata.model.jdbc.JDBCTable.createJDBCIndexColumn(JDBCTable.java:227)
        at org.netbeans.modules.db.metadata.model.jdbc.JDBCTable.createIndexes(JDBCTable.java:197)
        at org.netbeans.modules.db.metadata.model.jdbc.JDBCTable.initIndexes(JDBCTable.java:374)
        at org.netbeans.modules.db.metadata.model.jdbc.JDBCTable.getIndexes(JDBCTable.java:123)
        at org.netbeans.modules.db.metadata.model.api.Table.getIndexes(Table.java:100)
        at org.netbeans.modules.db.explorer.node.ColumnNode$1.run(ColumnNode.java:150)
Comment 5 vlad_konov 2009-03-11 13:28:20 UTC
Created attachment 78046 [details]
stacktrace
Comment 6 vlad_konov 2009-03-16 18:30:52 UTC
Build: NetBeans IDE Dev (Build 200902231810)
VM: Java HotSpot(TM) Client VM, 10.0-b23, Java(TM) SE Runtime Environment, 1.6.0_07-b06
OS: Windows XP, 5.1, x86

User Comments: 
trying to expand fields list in Services window (database server)

Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.db.metadata.model.jdbc.JDBCTable.createJDBCIndexColumn(JDBCTable.java:227)
        at org.netbeans.modules.db.metadata.model.jdbc.JDBCTable.createIndexes(JDBCTable.java:197)
        at org.netbeans.modules.db.metadata.model.jdbc.JDBCTable.initIndexes(JDBCTable.java:374)
        at org.netbeans.modules.db.metadata.model.jdbc.JDBCTable.getIndexes(JDBCTable.java:123)
        at org.netbeans.modules.db.metadata.model.api.Table.getIndexes(Table.java:100)
        at org.netbeans.modules.db.explorer.node.ColumnNode$1.run(ColumnNode.java:150)
Comment 7 vlad_konov 2009-03-16 18:31:06 UTC
Created attachment 78257 [details]
stacktrace
Comment 8 Exceptions Reporter 2009-03-27 12:01:34 UTC
This issue has already 10 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=144635
Comment 9 Jiri Rechtacek 2009-07-01 07:44:05 UTC
NB6.7 was released already - http://www.netbeans.org/community/releases/67/
Postpone fixing this issue on the next release.
Comment 10 Exceptions Reporter 2009-07-14 11:34:34 UTC
This issue already has 21 duplicates 
see http://statistics.netbeans.org/exceptions/detail.do?id=144635
Comment 11 Jiri Rechtacek 2009-07-15 11:50:24 UTC
core-main/rev/1c5f28647464
Comment 12 Quality Engineering 2009-07-16 05:59:16 UTC
Integrated into 'main-golden', will be available in build *200907160201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/1c5f28647464
User: Jiri Rechtacek <jrechtacek@netbeans.org>
Log: #155977: NullPointerException at JDBCTable.createJDBCIndexColumn
Comment 13 Jiri Rechtacek 2009-09-01 15:22:26 UTC
*** Issue 171089 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo