Bug 155833 - USABILITY: Show full class path of editing file(s)
USABILITY: Show full class path of editing file(s)
Status: RESOLVED DUPLICATE of bug 178094
Product: java
Classification: Unclassified
Component: Navigation
6.x
All All
: P3 with 1 vote (vote)
: TBD
Assigned To: Jan Jancura
issues@java
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-19 11:36 UTC by tprochazka
Modified: 2010-01-14 08:20 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
Example haw to show full class path to active file (33.19 KB, image/png)
2009-01-07 19:50 UTC, tprochazka
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tprochazka 2008-12-19 11:36:41 UTC
Project often contain more class with the same name, but in different packages. When I have opened more this classes is 
very complicated work with this in Netbeans.

Eclipse can synchronize project packages tree with actual editor (see Issue 147183). It also show full class path in 
window title.

InteliJ Idea has great panel with full path of actual file (see to attachments)

In Netbeans I can only move mouse to editor tab, when Netbeans show hint with full path. This is very uncomfortable.

Great would be:
- full class path in window title or great panel similar to Idea
- full class names in Ctrl+TAB panel (very simple and very very useful)
- possibility to synchronize project tree with active editor

Also would be great if Netbeans will be remember opened and selected folder in Projects Window and actual position in 
source when I close IDE. This work in Eclipse and Idea also.

They are most important usability problems during coding in Netbeans IDE.
Comment 1 Peter Pis 2008-12-22 11:08:08 UTC
Reassigning to editor for further evaluation.
Comment 2 Vitezslav Stejskal 2009-01-05 14:06:20 UTC
Would it be enough to show the FQN of a class in the navigator window (eg. ctrl+7)? The problem with FQNs in editor tabs
is that they are too long greatly limiting the number of tabs that you can see. I don't see any problem with having FQNs
in the ctrl+Tab panel.
Comment 3 tprochazka 2009-01-07 19:50:48 UTC
Created attachment 75560 [details]
Example haw to show full class path to active file
Comment 4 tprochazka 2009-01-07 19:58:23 UTC
I forgot upload example with FQN in InteliJ IDEA.

2vstejskal:

I didn't write about FQN in editors tabs.
I suggested add it to Windows title (like Eclipse do) or to special panel (like IDEA - see screnshot)
and to panel which open press ctrl+tab panel (into parenthesis after class name)
Comment 5 Jesse Glick 2010-01-14 08:20:12 UTC

*** This bug has been marked as a duplicate of bug 178094 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo