Bug 155700 - CalculatorClientApp project opens flagged with errors
CalculatorClientApp project opens flagged with errors
Status: RESOLVED FIXED
Product: usersguide
Classification: Unclassified
Component: Web Services
6.x
All All
: P2 (vote)
: TBD
Assigned To: Jeffrey Rubinoff
issues@webservices
:
Depends on: 105645
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-17 19:57 UTC by Vince Kraemer
Modified: 2009-02-19 23:29 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Vince Kraemer 2008-12-17 19:57:31 UTC
See http://www.netbeans.org/issues/show_bug.cgi?id=154562#desc6 for details.

basically, the project is flagged as broken when it is initially created/opened.

It looks like this is a regression from the behavior of the project in 6.0/6.1, though it may just be an issue with the
tutorial for the Calculator sample, which might have forgotten to mention something about the initial state of the two
apps when they open in the IDE...
Comment 1 Milan Kuchtiak 2009-01-05 12:42:50 UTC
Right, that's because JAX-WS java artifacts (proxy classes) are generated on project's Build.
As long as the project isn't built the java files, that reference those classes, are error badged.
This should be mentioned in tutorial.
Comment 2 Jeffrey Rubinoff 2009-01-12 08:32:48 UTC
Gentlemen,
The version of the tutorial for NB 6.5, available at http://www.netbeans.org/kb/docs/websvc/wsit.html, already includes
the warning
On NetBeans IDE 6.5, an error icon is shown for the CalculatorClientApp service because the IDE cannot find the WSDL for
the CalculatorWS service. After you deploy CalculatorApp, clean and build CalculatorClientApp and this problem is resolved. 
There is a similar warning in the section on SecureCalculatorApp.
Is this adequate?


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo