Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 155617 - Disallow userdir target folder for SQL files in the Save As dialog
Disallow userdir target folder for SQL files in the Save As dialog
Status: RESOLVED DUPLICATE of bug 154667
Product: platform
Classification: Unclassified
Component: Actions
6.x
All All
: P2 (vote)
: TBD
Assigned To: Stanislav Aubrecht
issues@platform
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-17 06:24 UTC by John Baker
Modified: 2008-12-22 10:45 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments
proposed fix (1.92 KB, text/plain)
2008-12-17 07:20 UTC, John Baker
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Baker 2008-12-17 06:24:07 UTC
For SQL files created through View Data or Execute Command, the Save As target folder is in the userdir.

This is a usability problem for the user to change the target folder to another folder outside the userdir everytime a
file is to be saved in another location.  Also, we want to prevent users from saving in the userdir, especially if the
user deletes the userdir than all SQL files will be removed.  Since SQL files usually aren't included in a project,
users will want to save them in another location than the userdir.

I'll provide a fix for this enhancement.  This is a hack but changes will be local and minimal.  If 
DataObject.getPrimaryFile() could be overridden then I could have made a change in the db module.

This issue is a higher priority than issue 154667 .
Comment 1 John Baker 2008-12-17 07:20:51 UTC
Created attachment 75064 [details]
proposed fix
Comment 2 Stanislav Aubrecht 2008-12-18 16:08:48 UTC
this seems like a duplicate of #154667, so please read my comments in issue 154667 

*** This issue has been marked as a duplicate of 154667 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo