Bug 155521 - [WSphere] Unable to deploy Ear to websphere 6.1
[WSphere] Unable to deploy Ear to websphere 6.1
Status: NEW
Product: serverplugins
Classification: Unclassified
Component: WebSphere
6.x
All Windows XP
: P2 (vote)
: 6.x
Assigned To: Petr Hejl
issues@serverplugins
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-16 08:02 UTC by mikfreeman
Modified: 2009-09-15 13:17 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Netbeans Messages File (419.56 KB, text/plain)
2008-12-16 08:03 UTC, mikfreeman
Details
Console Stack Trace on Deploy (3.24 KB, text/plain)
2008-12-16 08:04 UTC, mikfreeman
Details

Note You need to log in before you can comment on or make changes to this bug.
Description mikfreeman 2008-12-16 08:02:47 UTC
Unable to deploy basic EAR to websphere 6.1

Deploying the EAR manually to Websphere is successful

Netbeans 6.5
java version "1.6.0_02"

Websphere 6.1 (Webservices feature pack)
Comment 1 mikfreeman 2008-12-16 08:03:27 UTC
Created attachment 75000 [details]
Netbeans Messages File
Comment 2 mikfreeman 2008-12-16 08:04:29 UTC
Created attachment 75002 [details]
Console Stack Trace on Deploy
Comment 3 Petr Jiricka 2009-02-12 14:40:46 UTC
Not a stopper for NB 7 M2, but it would be good to fix this for the final release.
Comment 4 Petr Hejl 2009-03-19 20:22:57 UTC
I'm not able to reproduce this. Do you have admin security enabled? Can you deploy a web project?
Comment 5 mikfreeman 2009-03-20 09:47:40 UTC
Admin security is disabled.

I also tried to deploy a web app on its own and still got the below error

"java.lang.NoSuchMethodError:
org.eclipse.jst.j2ee.commonarchivecore.internal.helpers.ArchiveOptions.setParentClassLoader(Ljava/lang/ClassLoader;)V
"

Its odd as I can start and stop the server from netbeans and I can even see installed apps (Ones I installed manually).

One other thing I noticed in the server properties the only jar in the classes tab is j2ee.jar. Should there be more?

In addition the port in netbeans states its running on 8881. However I access an app deployed by RAD (Using it to
develop for now ) on port 9081.

I installed websphere with RAD and its the full version but maybe this is the problem.

Thanks for taking a look in any case.  

Comment 6 Jindrich Sedek 2009-04-15 15:25:13 UTC
there are some more informations from reporter, please reevaluate this issue
Comment 7 Petr Jiricka 2009-05-11 16:30:12 UTC
BTW, is this Windows-specific, or does it happen on all platforms?
Comment 8 mikfreeman 2009-05-12 08:38:12 UTC
I'm using Windows XP
Comment 9 mikfreeman 2009-05-18 11:44:36 UTC
Tried this in Netbeans 6.7 and ran into the same issue as 161284

What should the classes tab in the server properties contain?



By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo