Bug 15544 - Editor opens multiple copies of same file when error occurs in compilation
Editor opens multiple copies of same file when error occurs in compilation
Status: CLOSED WONTFIX
Product: cnd
Classification: Unclassified
Component: Terminalemulator
3.x
All All
: P3 (vote)
: 6.x
Assigned To: anovak
ivan
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-16 20:36 UTC by _ gtzabari
Modified: 2008-12-23 08:39 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
patch file - put into lib/patches (121.59 KB, application/octet-stream)
2001-09-18 11:57 UTC, anovak
Details
attached NPE (2.27 KB, text/plain)
2001-09-19 16:59 UTC, Jan Pichert
Details
ide.log (17.13 KB, text/plain)
2001-10-01 13:40 UTC, _ gtzabari
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ gtzabari 2001-09-16 20:36:37 UTC
dev build 200109110100
IBM JDK 1.3

- I hit F9 to compile a file in the editor. When errors are found they should up in the output window so I double-click on them.
- Instead of jumping to the line number in the file which is already open, the editor opens up a second (sometimes a third) window of the same file and jumps to the 
line number there.
- The editor should use the window which is already open
- I'm in MDI mode
Comment 1 Jan Zajicek 2001-09-17 14:22:27 UTC
Confirmed on my Solaris too in build #20010914-containing terminal
emulator.

Changing Platform and OS. Also increassing priority to P1 (If do not
agree, please change).

It is 100% regression and should be fixed into the beta.

Note, that I verified it with only one mounted filesystem (sampledir),
so this isn't the case when the source is mounted more than once!
Comment 2 Jan Zajicek 2001-09-17 14:45:56 UTC
OK, changing owner.
Comment 3 anovak 2001-09-17 15:33:43 UTC
It works for me as well as for Jan Zajicek. Please, describe steps how
to reproduce this problem.
Comment 4 Jan Zajicek 2001-09-17 15:40:33 UTC
Ok, It's true that I cannot reproduce it now. But is also true that I
was able to reproduce it before I have restarted the ide
(build#20010914). Now it is hard to say what could cause such
behaviour. I will keep an eye on it ;-) So sorry for wide distrurb. Honza.
Comment 5 _ gtzabari 2001-09-17 17:30:29 UTC
This is 100% reproducible on my end.

1) Take dev build 200109110100
2) Open a source files by double-clicking on it from the explorer
3) Cause some sort of error in the source-code and hit F9 to compile
4) Netbeans will open a second instance of the file (even though one 
is already open) and jump to the line containing the error
Comment 6 _ gtzabari 2001-09-17 17:30:53 UTC
Reopening issue
Comment 7 anovak 2001-09-18 11:57:59 UTC
Created attachment 2579 [details]
patch file - put into lib/patches
Comment 8 anovak 2001-09-18 11:59:43 UTC
I still cannot reproduce it. I made some changes into a related code
last week - can you try whether the attached patch makes it working
for you?
Comment 9 Jan Zajicek 2001-09-19 13:30:23 UTC
Gili, do you see the behaviour in the latest builds? If so, does the
patch solve the problem? Thanks.
Comment 10 Jan Pichert 2001-09-19 16:28:10 UTC
dev build 3.3 20010919
IBM JDK 1.3 
W2K

After clicking on the error in the output window I get an NPE.
java.lang.NullPointerException
        at org.netbeans.editor.Annotations.removeAnnotation
(Annotations.java:213)
Comment 11 Jan Pichert 2001-09-19 16:59:16 UTC
Created attachment 2605 [details]
attached NPE
Comment 12 _ gtzabari 2001-09-20 06:43:57 UTC
Seems like the issue is fixed in dev build 20010919 
but I'm not sure because the output window looks 
completely different and acts weird ;) Personally I 
preferred the old look..

Anyway, I guess this is fixed..
Comment 13 anovak 2001-09-20 11:10:33 UTC
Ok, I am closing it as not reproducible.
Comment 14 _ gtzabari 2001-09-29 22:40:32 UTC
Issue is back in dev build 200109280100
Comment 15 anovak 2001-10-01 09:39:20 UTC
I still cannot reproduce it :-(. Gilli, have you tried the patch? Any
results?
Comment 16 _ gtzabari 2001-10-01 13:39:27 UTC
The patch doesn't work. I've included ide.log for 
your review. No exceptions are thrown when I 
double-click on the error in the output window, but 
there are a few thrown before it. You will notice 
the last line in the log is me trying to compile 
the file.
Comment 17 _ gtzabari 2001-10-01 13:40:09 UTC
Created attachment 2773 [details]
ide.log
Comment 18 _ gtzabari 2001-10-01 13:40:50 UTC
Also, when you try to repro this issue, please make 
sure you're using a fresh userDir and try IBM JDK 
1.3, not Sun's.
Comment 19 anovak 2001-10-08 08:16:42 UTC
We have resolved a similar bug caused by old xerxces.jar in IBM's JDK
distribution. Is this one still valid? 
Comment 20 _ gtzabari 2001-10-08 18:51:58 UTC
As I explained to you, OS/2's distribution doesn't 
come with XERCES.JAR at all so your explanation 
doesn't work for this bug. Something else is the 
cause or this is the result of multiple issues. So 
yes, this is still a valid issue.

I'm unable to repro it under dev build 200110040910 
but since I had no problem reproing under 
200109280100 (6 days beforehand) I recommend we 
leave this issue open under REMIND so we can check 
if it's still around a month from now.
Comment 21 Lukas Hasik 2002-01-10 17:38:43 UTC
Gili,

please reopen if it isn't gone.

Thanks.
Comment 22 Quality Engineering 2008-12-23 08:39:22 UTC
moving terminal emulator issues to terminalemulator component.
To see the correct version and target milestone of this issue look at Issue
Activity table.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo