Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 155304 - Cannot explore databases in Database Explorer
Cannot explore databases in Database Explorer
Status: RESOLVED DUPLICATE of bug 150660
Product: db
Classification: Unclassified
Component: MySQL
6.x
Other Linux
: P3 (vote)
: TBD
Assigned To: David Vancouvering
issues@db
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-12 09:06 UTC by stefanhinz
Modified: 2008-12-12 17:16 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Messages log file for "cannot explore database objects" bug (36.06 KB, text/plain)
2008-12-12 09:34 UTC, stefanhinz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description stefanhinz 2008-12-12 09:06:42 UTC
I can connect without issues to MySQL instances (servers) locally and remotely. Depending on which MySQL accounts I use
I see the databases that I have privileges for. With an administrative MySQL account, I can create and drop databases.
So far, all works as expected.

But I can't expand the database icons to see the contained objects (e.g. tables). Double-clicking does nothing, and
right-clicking gives the options of "Connect" and "Delete", nothing else. I'd expect to see tables for the databases
that contain tables, for example for my "test" database:

mysql> show tables from test;
+---------------------+
| Tables_in_test      |
+---------------------+
| #123||@@            |
| huh                 |
| ingo                |
| my_first_base_table |
| parts               |
| parts_copy          |
| test                |
| uptest              |
+---------------------+
8 rows in set (0.08 sec)

But the NetBeans Database Explorer shows nothing. Bugger.

Maybe this is related to bug #155301 (http://www.netbeans.org/issues/show_bug.cgi?id=155301) which I just reported, I
don't know.
Comment 1 John Baker 2008-12-12 09:12:31 UTC
No, not related to issue 155301.

Could you attach your messages.log file from the userdir
Comment 2 stefanhinz 2008-12-12 09:34:29 UTC
Created attachment 74894 [details]
Messages log file for "cannot explore database objects" bug
Comment 3 David Vancouvering 2008-12-12 17:16:47 UTC
Yes, Stefan, this is annoying and confusing.  This is a duplicate of issue 150660 which we *hope* to get to in this release.

Meanwhile, right-click, choose Connect, a new connection will be made for you (it's a new node in the tree, see below
the MySQL node), and you can open *that* and browse your tables.

We really do want to fix that, thanks for taking the time to log the issue

*** This issue has been marked as a duplicate of 150660 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo