Bug 155302 - A11y problems caused by Ctrl-Tab
A11y problems caused by Ctrl-Tab
Status: VERIFIED FIXED
Product: platform
Classification: Unclassified
Component: Window System
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Stanislav Aubrecht
issues@platform
issue_reviewed 65fixes3-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-12 08:27 UTC by Nikolay Molchanov
Modified: 2009-03-16 17:22 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
proposed patch (1.13 KB, patch)
2008-12-19 09:41 UTC, Stanislav Aubrecht
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Nikolay Molchanov 2008-12-12 08:27:51 UTC
There is an A11y bug in Netbeans IDE - it uses Ctrl-Tab to select a file in Editor.
As a result we cannot fix A11y problems in the Sun Studio IDE, which is based on Netbeans IDE,
because Ctrl-Tab is a standard way to navigate to the next focusable component.

I think it is ok to continue to use Ctrl-Tab inside the Editor window, but do not catch
it when the focus is inside any other window. 

Here is an example to illustrate the problem.
1. Create a sample Java project, say "MarsRoverViewer".
2. Press F7 ("Step Into") to start debugging.
3. Press "Alt-Shift-1" to navigate to the "Local Variables" window
4. Use arrows and "Tab" to go through the variables (so far so good)
5. Press "Ctrl-Tab" - this is supposed to navigate to the next focusable component: Breakpoints

But instead a list of open files is displayed in the popup, and the focus is moved to the Editor window (?!).
This is a serious A11y bug. I set high priority P2, because we need this to be fixed in current release.
Comment 1 Miloslav Metelka 2008-12-15 10:01:45 UTC
IMHO we should retain Ctrl-Tab meaning as is since most IDEs use it in a similar way like we do.
Anyway reassigning to core/ws since Ctrl+Tab is handled there.
Comment 2 Lukas Hasik 2008-12-15 11:28:19 UTC
reproducible with dev builds
Comment 3 Stanislav Aubrecht 2008-12-19 09:40:06 UTC
i'll attach a patch that does the job. however i recommend turning the new ctrl+tab behavior on in sun studio builds
only (using e.g. system property)
Comment 4 Stanislav Aubrecht 2008-12-19 09:41:16 UTC
Created attachment 75174 [details]
proposed patch
Comment 5 Stanislav Aubrecht 2009-01-09 11:27:28 UTC
nikmolchanov, is the patch working for you?
Comment 6 Nikolay Molchanov 2009-01-09 17:35:10 UTC
I think the suggested fix is exactly what we need.
I cannot apply this patch, because we do not build Netbeans -
we use "binary delivery" model to integrate the Netbeans IDE 
in the Sun Studio build. So we need this fix in Netbeans 7.

Thanks you very much for the fix!
Comment 7 Stanislav Aubrecht 2009-01-13 14:37:07 UTC
fixed

when system property "netbeans.winsys.ctrltab.editoronly" is set to true then ctrl-tab switching is active only when
input focus is in an editor window.


119d5545bb1e
Comment 8 Quality Engineering 2009-01-28 09:53:24 UTC
Integrated into 'main-golden', will be available in build *200901280348* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/119d5545bb1e
User: S. Aubrecht <saubrecht@netbeans.org>
Log: #155302 - allow ctrl-tab document switching in editor mode only (when requested)
Comment 9 Alexander Pepin 2009-02-02 14:19:26 UTC
should be included into patch3 for NB6.5
Comment 10 matusdekanek 2009-02-23 16:01:50 UTC
marking verified, mentioned behaviour is not observed at all
Comment 11 Stanislav Aubrecht 2009-02-26 08:41:14 UTC
backporting the fix to release65_fixes: 7ca0aaf873fc
Comment 12 Alexander Pepin 2009-02-26 14:02:08 UTC
fix failed in build 20090226
Ctrl+Tab always switches editor tabs

Steps to reproduce:
- create any C/C++ project
- do step into
- open Local Variables
- select any variable
- try to use Tab and Arrow keys, they work
- press Ctrl+Tab
Result: List of files opened in the editor appears instead of navigating to Call Stack debugging window 
Comment 13 Stanislav Aubrecht 2009-02-26 14:06:29 UTC
it is fixed, please read my comments to this issue:

> when system property "netbeans.winsys.ctrltab.editoronly" is set to true then ctrl-tab switching is active only when
> input focus is in an editor window.
Comment 14 Alexander Pepin 2009-02-26 14:32:04 UTC
yes, with netbeans.winsys.ctrltab.editoronly=true a list of files does not appear but debugging views do not switch
either. Is it right behavior?
Comment 15 Stanislav Aubrecht 2009-02-26 14:44:25 UTC
> As a result we cannot fix A11y problems in the Sun Studio IDE, which is based on Netbeans IDE,
> because Ctrl-Tab is a standard way to navigate to the next focusable component.

i presume that debugger views should never switch on ctrl-tab key, instead 'next focusable component' should be
navigated to - whatever that is at the moment
Comment 16 Alexander Pepin 2009-02-26 15:52:31 UTC
Does NetBeans follow the same rules? I mean Ctrl-Tab should navigate to the next focusable component.
Comment 17 Stanislav Aubrecht 2009-02-26 16:30:18 UTC
(shift) TAB is the default focus navigation key. ctrl+tab is used to switch panes in JTabbedPane and to move focus out
of JTable (i think)
Comment 18 Alexander Pepin 2009-02-26 16:59:02 UTC
Thanks,
my concern is about ctrl-tab functionality mentioned in bug's description. Who is responsible for implementing that
functionality? If the issue is only about not catching ctrl-tab in other windows except editor then everything is OK.
Comment 19 matusdekanek 2009-03-09 11:26:45 UTC
Product Version: NetBeans IDE 6.5.1 (Build 200903050001)
Java: 1.6.0_12; Java HotSpot(TM) Client VM 11.2-b01
System: Linux version 2.6.27-11-generic running on i386; UTF-8; en_US (nb)

This issue is still not fixed, even with -J-Dorg.netbeans.winsys.ctrltab.editoronly=true option it does not change (am 
I doing something wrong?). Ctrl-tab still changes focus to edit windows and switches between them, exactly as mentioned 
in nikmolchanov`s report.
I am therefore reopening this issue. Please tell me if I got something wrong and I will mark it again as fixed.

Anyway, I do not find it to be a signifficant drawback, I would lower the priority to p3(or even lower, frankly there 
are some more signifficant issues in p3 cathegory than this one..).
Comment 20 matusdekanek 2009-03-09 15:43:00 UTC
My fault, issue is fixed. I used incorrect option, correct one is as mentioned before ( -J-
Dnetbeans.winsys.ctrltab.editoronly=true ).
Works fine, closing issue.
Comment 21 matusdekanek 2009-03-09 15:44:02 UTC
marking verified


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo