Bug 15516 - Broken toolbars after upgrade from 3.2 to 3.3
Broken toolbars after upgrade from 3.2 to 3.3
Status: CLOSED DUPLICATE of bug 15547
Product: projects
Classification: Unclassified
Component: Ant
3.x
Sun SunOS
: P1 (vote)
: 3.x
Assigned To: Jesse Glick
issues@projects
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-14 11:54 UTC by Jan Zajicek
Modified: 2003-06-30 14:46 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Zajicek 2001-09-14 11:54:51 UTC
Start nb3.3 using userdir from 3.2. You will see all toolbars in all workspaces.
You cannot move with toolbars, no popup over them, their border is big.

P1, because compatibility issue and this should be fixed into first 3.3 beta.
Comment 1 David Simonek 2001-09-17 12:47:59 UTC
The probable reason is that xml config files storing toolbar
configurations were not found. See methods
Workspace.set/getToolbarConfigName.
Comment 2 Radko Najman 2001-09-18 17:40:18 UTC
It is not a window system bug but an ant module bug. If you upgrade from 3.2 to 3.3 
using userdir form 3.2, toolbar configuration files are recognized by 
AntProjectDataLoader instead of XMLDataLoader. "xml" extension is serialized for 
AntProjectDataLoader and used in 3.3 instead of MIME type which should be used rather 
then the extension. That's why XML files are recognized by AntProjectDataLoader.

Proposed fix (diff follows): add a version ID into AntProjectDataLoader and implement 
writeExternal() method which will externalize this ID. Try to read ID in readExternal() 
method. If it is not possible to read ID, remove "xml" extension and MIME type will be 
used instead of the extension. 


37a38
>     private static final int VERSION = 1;
86a88
>             oi.readByte();
89a92,94
>         } catch (IOException exc) {
>             getExtensions().removeExtension("xml"); //NOI18N
>             initialize();
92c97,102
<
---
>
>     public void writeExternal (ObjectOutput oo) throws IOException {
>         super.writeExternal (oo);
>         oo.writeByte(VERSION);
>     }
>
Comment 3 Jesse Glick 2001-09-19 09:50:27 UTC
Already reported.

*** This issue has been marked as a duplicate of 15547 ***
Comment 4 Jan Zajicek 2001-09-27 11:12:30 UTC
Fixed for upgrading from 3.2, but still occurs when using Import
wizard when first starting ide and perform importing from nb3.1 or
FFJ2.0CE. Can ant loader still be involved?
Comment 5 Jesse Glick 2001-09-27 19:30:47 UTC
I don't know, it's possible the fix only worked correctly for imports
from 3.2, though I thought it should be fine for all; I will try to
figure out what is going on.
Comment 6 Jesse Glick 2001-09-29 10:33:43 UTC
This is still the same, please use #15547 for details...

*** This issue has been marked as a duplicate of 15547 ***
Comment 7 Quality Engineering 2003-06-30 14:44:22 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.

Comment 8 Quality Engineering 2003-06-30 14:46:53 UTC
Resolved for 3.3.x or earlier, no new info since then -> closing.



By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo