Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 155153 - Refactoring in readonly blocks failed
Refactoring in readonly blocks failed
Status: RESOLVED DUPLICATE of bug 106831
Product: guibuilder
Classification: Unclassified
Component: Code
6.x
All All
: P3 (vote)
: TBD
Assigned To: issues@guibuilder
issues@guibuilder
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-10 15:39 UTC by christian255
Modified: 2008-12-16 11:48 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description christian255 2008-12-10 15:39:47 UTC
The refactoring dosen't work in "read-Only-blocks" with "custom code" inside.

Please look at this image. 

http://www.marquardtnet.info/cecke/links.7/bild4.jpg

The refactoring of the variable FORMULARIMAGE failed, because the custom code in the line 
setIconImage(de.formulareditor.helper.Konstanten.FORMULARIMAGE);
in in a read-Only-block.
Comment 1 christian255 2008-12-10 15:52:38 UTC
The refactoring in read-only-blocks failed.
Please look at this picture:

http://www.marquardtnet.info/cecke/links.7/bild4.jpg

The refactoring from FORMULARIMAGE failed, because the line
>> setIconImage(de.formulareditor.helper.Konstanten.IMG_FORMULAR);
is a custom code in a read-only-block
Comment 2 Jan Pokorsky 2008-12-11 15:03:58 UTC
form refactoring issue, reassigning
Comment 3 Jiri Vagner 2008-12-16 11:48:23 UTC
Thank you for your report. Yes, you are right, this scenarion (rename of non-component variable) is not actually
supported. Inside custom code we support only ...
http://wiki.netbeans.org/GUIBuilderRefactoring#section-GUIBuilderRefactoring-7.UpdatingEmbeddedCustomCode

Thank you again for your report, I'm going to assign this issue into out refatoring umbrella feature.

*** This issue has been marked as a duplicate of 106831 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo