Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 155034 - Address breakpoints do not work
Address breakpoints do not work
Status: CLOSED DUPLICATE of bug 133134
Product: cnd
Classification: Unclassified
Component: Debugger
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Egor Ushakov
issues@cnd
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-09 15:14 UTC by Alexander Pepin
Modified: 2009-06-25 10:59 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
gdb log (13.00 KB, text/plain)
2008-12-09 15:19 UTC, Alexander Pepin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Pepin 2008-12-09 15:14:54 UTC
Steps to reproduce:
- create Welcome sample project
- do step into project
- switch to Disassembler view
- set an address breakpoint in assembler line after "if (argc > 1) {" statement 
- switch to source view
- set a line BP in the line with "return" statement
- do continue
Result: Debugger ignores an address breakpoint and stops only at line BP.
Gdb log will be attached.
Comment 1 Alexander Pepin 2008-12-09 15:19:05 UTC
Created attachment 74752 [details]
gdb log
Comment 2 Egor Ushakov 2008-12-11 12:00:36 UTC

*** This issue has been marked as a duplicate of 133134 ***
Comment 3 Alexander Pepin 2008-12-12 16:17:18 UTC
closed as the issue is a consequence of issue #133134


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo