Bug 154961 - NullPointerException at org.netbeans.modules.python.api.PythonPlatformManager.findPlatformProperties
NullPointerException at org.netbeans.modules.python.api.PythonPlatformManager...
Status: VERIFIED WORKSFORME
Product: python
Classification: Unclassified
Component: Code
6.x
All All
: P1 (vote)
: TBD
Assigned To: jymen
nbpythonqa
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-08 18:49 UTC by tonybeckham
Modified: 2009-02-19 22:58 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (530 bytes, text/plain)
2008-12-08 18:49 UTC, tonybeckham
Details
Warning message regarding Jython version (41.49 KB, text/plain)
2008-12-08 18:53 UTC, tonybeckham
Details
Warning message regarding Jython version (41.49 KB, image/png)
2008-12-08 18:53 UTC, tonybeckham
Details

Note You need to log in before you can comment on or make changes to this bug.
Description tonybeckham 2008-12-08 18:49:36 UTC
Build: NetBeans IDE Dev (Build 20081208154120)
VM: Java HotSpot(TM) Client VM, 1.5.0_16-133, Java(TM) 2 Runtime Environment, Standard Edition, 1.5.0_16-b06-284
OS: Mac OS X, 10.5.5, i386

User Comments:
tonybeckham: Opened Python IDE from zip on Hudson, build 252.  On launch there was a warning that Jython requested version >+2.5 but only 0.115 was found.  I selected disable and continue.  After the IDE launched I selected Python Platforms from the Options menu and exception was thrown.



Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.python.api.PythonPlatformManager.findPlatformProperties(PythonPlatformManager.java:375)
        at org.netbeans.modules.python.api.PythonPlatformManager.autoDetect(PythonPlatformManager.java:426)
        at org.netbeans.modules.python.api.PythonPlatformManager$1.run(PythonPlatformManager.java:182)
        at org.openide.util.RequestProcessor$Task.run(RequestProcessor.java:573)
        at org.openide.util.RequestProcessor$Processor.run(RequestProcessor.java:1005)
Comment 1 tonybeckham 2008-12-08 18:49:41 UTC
Created attachment 74707 [details]
stacktrace
Comment 2 tonybeckham 2008-12-08 18:53:13 UTC
Created attachment 74708 [details]
Warning message regarding Jython version
Comment 3 tonybeckham 2008-12-08 18:53:21 UTC
Created attachment 74709 [details]
Warning message regarding Jython version
Comment 4 tonybeckham 2008-12-08 19:27:45 UTC
Reproducible on Linux too
Comment 5 Peter Lam 2008-12-09 01:04:44 UTC
I see the same on Windows platform. I think this is related to issue 154962 but will leave it open for dev engrs to
evaulate.
Comment 6 jymen 2008-12-10 10:42:59 UTC
This was relative to null output back from Execution service when executing platform_info.py environment script the pb
has been fixed since #281
Comment 7 tonybeckham 2008-12-10 18:27:40 UTC
Still happening with build 288
Comment 8 jymen 2008-12-11 11:25:04 UTC
I got that problem at the beginning of the week and made a debug session on it since it is definitivelly a show stopper
( even for me ;=) )  ; I saw that the NPE was relative to RequestProcessor not sending back the standard output capture
of the  platform_info.py python environment collector script. Allthough the mercury migration to main does not show the
modification history of PythonPlatformManager That part of the nbPython code has not changed for some times (I made a
diff with python65 version of PythonPlatformManager where it works and it shows it's identicall to main).
I was looking for filling an issue to RequestProcessor code owner outside nbpython project, when I saw it works again
(at least on LINUX) around build #281. 

I did a successfull test yesterday and new test this morning after a pull from mercurial playing with new python
platforms and autodetect and it still works like a charm .... at least on linux.

So the status for me is definitively works for me ( at least on linux ) I don't change the status of the log anyway
since you still seem to have problem ... but sorry I cannot reproduce now this problem anymore on my pc.

If you still have the problem it would be interesting to assign this ticket to netbeans core module owner of
org.netbeans.api.extexecutionExecution.Descriptor.InputProcessorFactory() with the issue :
regression : empty returned content on non empty standard output stream. 

Jean-Yves
 
   
Comment 9 tonybeckham 2008-12-11 17:16:38 UTC
With latest build (301) no longer an issue.
Comment 10 tonybeckham 2008-12-11 17:18:52 UTC
Verified

Product Version: NetBeans IDE Dev (Build 20081211143423)
Java: 1.5.0_16; Java HotSpot(TM) Client VM 1.5.0_16-133
System: Mac OS X version 10.5.5 running on i386; MacRoman; en_US (nb)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo