Bug 154845 - Folders containing NetBeans settings shouldn't be in user's home folder
Folders containing NetBeans settings shouldn't be in user's home folder
Status: RESOLVED DUPLICATE of bug 207507
Product: db
Classification: Unclassified
Component: Derby
6.x
PC Windows Vista
: P3 (vote)
: TBD
Assigned To: Libor Fischmeistr
issues@db
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-06 21:34 UTC by ondrejbohaciak
Modified: 2014-01-07 13:03 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ondrejbohaciak 2008-12-06 21:34:15 UTC
There are several folders containing NetBeans settings and other related data that reside in user's home folder. I'm 
using Windows Vista, let's say my username is Ondrej. My user folder (%UserProfile%) is redirected to disk D:\ 
(previously C:\Users\Ondrej). After installing and running NetBeans, these extra folders are created:

D:\.netbeans
D:\.netbeans-derby
D:\.netbeans-registration
C:\Users\Ondrej\.netbeans

I would like it very much if these were relocated to either %ProgramData% directory or to %UserProfile%\My Documents. 
These are the proper folders for kkeping user/machine specific program data. I like to keep my folders tidy ;)
Comment 1 Jaroslav Tulach 2008-12-17 09:07:47 UTC
Btw. You can redirect .netbeans whereever you want with --userdir parameter. For the others, it depends on what Java 
runtime thinks is your home directory. Which apparently is D:\. If anyone can help you, then it would be the laucnher 
maintainer, I guess.
Comment 2 Jaroslav Tulach 2010-04-02 18:27:16 UTC
Assigning to db, because of .netbeans-derby.
Comment 3 matthias42 2014-01-07 13:03:34 UTC

*** This bug has been marked as a duplicate of bug 207507 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo