Bug 154752 - Awkward to create a new layer in a project
Awkward to create a new layer in a project
Status: RESOLVED FIXED
Product: apisupport
Classification: Unclassified
Component: Project
6.x
All All
: P3 with 1 vote (vote)
: 7.1
Assigned To: Jesse Glick
issues@apisupport
: PLAN, UI
: 199140 201772 (view as bug list)
Depends on: 184359
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-05 14:20 UTC by Jesse Glick
Modified: 2011-09-08 20:12 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2008-12-05 14:20:08 UTC
You can decide to create a module with or without a layer. In fact, it is a bad idea to create a module initially with a
layer, because you might never need it, and this would just waste resources.

On the other hand, you _do_ sometimes want to add a layer to an existing project, without running any of the standard
wizards which add a layer entry. This can only be done now my manually creating the XML file and its registration in
manifest.mf, or by running one of those wizards and then undoing most of its effects.

IMHO the New Project wizard should not offer to add a layer. Instead, there should be an "Empty Layer" template in the
Module Development category.
Comment 1 rmichalsky 2008-12-05 16:13:36 UTC
Ok, I agree. IMHO that's an enhancement.
Comment 2 Jesse Glick 2011-06-03 14:53:43 UTC
*** Bug 199140 has been marked as a duplicate of this bug. ***
Comment 3 Jesse Glick 2011-07-15 14:22:05 UTC
core-main #b3b81ce11cab
Comment 4 Jesse Glick 2011-07-15 14:28:10 UTC
Also: https://svn.codehaus.org/mojo/trunk/mojo/mojo-archetypes/nbm-archetype revision 14326
Comment 5 Quality Engineering 2011-07-16 13:56:01 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/b3b81ce11cab
User: Jesse Glick <jglick@netbeans.org>
Log: #154752: wizard to create a new XML layer.
Comment 6 Jesse Glick 2011-09-08 20:12:11 UTC
*** Bug 201772 has been marked as a duplicate of this bug. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo