Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 154634 - Add "Move Up" and "Move Down" buttons to "Create Table" dialog for moving columns
Add "Move Up" and "Move Down" buttons to "Create Table" dialog for moving col...
Status: RESOLVED FIXED
Product: db
Classification: Unclassified
Component: Code
6.x
All All
: P2 (vote)
: 7.4
Assigned To: Jaroslav Havlin
issues@db
:
: 65758 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 17:56 UTC by Roman Mostyka
Modified: 2013-02-16 01:53 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Mostyka 2008-12-04 17:56:20 UTC
1. Connect to some DB.
2. Expand it's node, rightclick "Tables" node and choose "Create Table...".
3. Enter table name, set name and type for first column.
4. Add second column and set name and type for it.

Result: If user wants to change columns order, there is only one workaround:
Change first column name to second and do the same for first column type. After this do the same actions for second
column, but with values from first column.
But if user has 10 columns and it is necessary to change order, it will be very inconvenient to do.
We need add some buttons like "Move Up" and "Move Down" for this purpose.
Comment 1 Jiri Rechtacek 2009-10-16 14:11:09 UTC
Reassigned to new owner.
Comment 2 matthias42 2012-08-20 14:57:28 UTC
*** Bug 65758 has been marked as a duplicate of this bug. ***
Comment 3 Jaroslav Havlin 2013-02-14 10:10:49 UTC
http://hg.netbeans.org/core-main/rev/806bbc5dd3a2
Fixed.
Comment 4 Quality Engineering 2013-02-16 01:53:56 UTC
Integrated into 'main-golden', will be available in build *201302152300* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/806bbc5dd3a2
User: Jaroslav Havlin <jhavlin@netbeans.org>
Log: #154634: Add "Move Up" and "Move Down" buttons to "Create Table" dialog for moving columns


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo