Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 154629 - Save disabled after entering diagram documentation, lose text
Save disabled after entering diagram documentation, lose text
Status: RESOLVED FIXED
Product: uml
Classification: Unclassified
Component: General Diagram
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Sergey Petrov
issues@uml
:
: 161122 162681 (view as bug list)
Depends on:
Blocks: 154628
  Show dependency treegraph
 
Reported: 2008-12-04 16:27 UTC by thomasmatzner
Modified: 2009-04-15 10:03 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description thomasmatzner 2008-12-04 16:27:38 UTC
1. Save your model, so that the save menu options and icons are disabled.

2. Select a diagram by either double clicking it in the projects window, or clicking on the diagram background in the
editor pane.

3. Enter some diagram documentation via the documentation window.

4. Try to save the documentation -- this is impossible, as the save options are still disabled.

5. Modify anything in your model, so that save options are available again.

6. Navigate back to the diagram for which you entered documentation -- the documentation is lost.

If you perform some modification between steps 1 and 2, you will be able to save after entering your documentation, and
the documentation will be persisted. If you are not aware of that flaw, however, you might enter your documentation,
navigate somewhere else, and not be aware that on your next save the documentation will be gone.
Comment 1 Sergey Petrov 2008-12-04 17:51:07 UTC
I can reproduce disabled save ater entering documentation and even stitching from documentation window or another
element after.
But after I got diagram selected again I see entered documentation and it can be saved after some model modification.
Any hints, more steps?
Comment 2 Sergey Petrov 2008-12-04 17:52:31 UTC
anyway good to mark model as dirty after documentation changes.
Comment 3 Sergey Petrov 2008-12-04 17:55:14 UTC
ok, after save, close, open documentation is missed.
Comment 4 Sergey Petrov 2008-12-08 20:32:31 UTC
20fc2cdf1331 fixed, wait for integration comment to see in daily.
Comment 5 Quality Engineering 2008-12-12 17:30:37 UTC
Integrated into 'main-golden', will be available in build *200812121401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/20fc2cdf1331
User: sergeyp@netbeans.org
Log: fix #154628,#154629 - fix diahgram documentation import from 6.1 files and alsosupport for diagram documentation in new release
Comment 6 Peter Lam 2008-12-17 17:14:24 UTC
verified in latest trunk build 20081217.
It's a little odd because making changes in the documentation window does not immediately mark the diagram dirty until a
click back on the diagram or something on the diagram, but it works so no text in doc gets lost. Maybe a separate issue
should be filed to enhance that changes made in doc window immediately mark diagram dirty.
Comment 7 rbalada 2009-01-13 14:52:30 UTC
The changeset http://hg.netbeans.org/main/rev/20fc2cdf1331 has been transplanted into release65_fixes repository as
http://hg.netbeans.org/release65_fixes/rev/e039453bb065
Comment 8 kaa 2009-01-22 17:09:59 UTC
reproducible with 65patch2:
added 2 diagrams,
for the first one I was able to save doc window content,
for the second one - all save options were disabled.
Comment 9 pgebauer 2009-01-23 12:54:26 UTC
The issue has been moved into 65patch3. Changes in the release65_fixes branch have been rolled back.

http://hg.netbeans.org/release65_fixes/rev/65f7d5c5866c

Comment 10 Sergey Petrov 2009-01-29 15:39:20 UTC
does it mean fix failed in trunk or transfer to 6.5 failed?
Comment 11 Sergey Petrov 2009-02-04 09:54:49 UTC
restore status, feel free to reopen or ask me if smth is reproducible or additional actions are required for patch
Comment 12 Sergey Petrov 2009-03-25 13:51:39 UTC
*** Issue 161122 has been marked as a duplicate of this issue. ***
Comment 13 pgebauer 2009-04-08 14:01:55 UTC
The status whiteboard "65fixes4-candidate" has been removed.
At this time our proactive patches for the NetBeans 6.5.x IDE have concluded.

If you own a Sun service plan contract for NetBeans, you may wish to contact
Sun Service http://www.sun.com/contact/support.jsp to request a fix via the
product defect escalation process.

For more information on purchasing a Sun service plan contract for NetBeans,
refer to the service plan item "Sun Software Service Plans (S3P) for Developers"
in the Sun Service table found on our NetBeans Support Resources
page http://www.netbeans.org/kb/support.html
Comment 14 Sergey Petrov 2009-04-15 10:03:45 UTC
*** Issue 162681 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo