Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 154628 - Diagram documentation lost on upgrade 6.1 to 6.5
Diagram documentation lost on upgrade 6.1 to 6.5
Status: RESOLVED FIXED
Product: uml
Classification: Unclassified
Component: General Diagram
6.x
All Windows XP
: P2 (vote)
: 6.x
Assigned To: Sergey Petrov
issues@uml
:
Depends on: 154629
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 16:06 UTC by thomasmatzner
Modified: 2009-04-08 14:01 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description thomasmatzner 2008-12-04 16:06:43 UTC
After migrating UML diagrams (class, state, sequence, activity) from 6.1 to 6.5, documentation present on diagram level
is lost.

This is possibly due to the fact that in 6.1 those documentations were kept in the .etlp files, whereas in 6.5 they are
part of the .etd file.

Documentation of single elements of a diagram, like an invocation in an activity diagram, appears to be unaffected by this.
Comment 1 thomasmatzner 2008-12-04 16:35:42 UTC
Is there any way, before 7.0, to at least warn the user (together with the warning message when the diagrams are
migrated) that this documentation will be lost?
Comment 2 Sergey Petrov 2008-12-04 18:50:13 UTC
issue 154629 may be the root cause, i.e. bad support for diagram docmantation in 6.5
Comment 3 Sergey Petrov 2008-12-05 05:23:43 UTC
it's unexpected behavior and should be fixed and if possible go to 6.5 patch also(if will fit in patch schedule), you
can also restore 6.1 diagrams from DiagramBackup foolder and open in 6.1.
Comment 4 Sergey Petrov 2008-12-08 20:32:48 UTC
20fc2cdf1331 fixed, wait for integration comment to see in daily.
Comment 5 Quality Engineering 2008-12-12 17:26:19 UTC
Integrated into 'main-golden', will be available in build *200812121401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/20fc2cdf1331
User: sergeyp@netbeans.org
Log: fix #154628,#154629 - fix diahgram documentation import from 6.1 files and alsosupport for diagram documentation in new release
Comment 6 Peter Lam 2008-12-17 18:00:22 UTC
verified in latest trunk build 20081217 for all diagram types.
Comment 7 rbalada 2009-01-13 14:52:06 UTC
The changeset http://hg.netbeans.org/main/rev/20fc2cdf1331 has been transplanted into release65_fixes repository as
http://hg.netbeans.org/release65_fixes/rev/e039453bb065
Comment 8 kaa 2009-01-22 17:41:08 UTC
reproducible with 65patch2:
UML doc for was lost after migration.
I used class, state, sequence, activity diagrams created with NetBeans 6.1
Comment 9 pgebauer 2009-01-23 12:54:33 UTC
The issue has been moved into 65patch3. Changes in the release65_fixes branch have been rolled back.

http://hg.netbeans.org/release65_fixes/rev/65f7d5c5866c

Comment 10 Sergey Petrov 2009-01-30 11:41:59 UTC
what does it mean, it's marked as fixed in 7.0m1, why it's reopened based on fail in 6.5 patch2.
What I should do, may it be because of some part of commits is missed or someone can reproduce the same with dev build?
Comment 11 pgebauer 2009-02-01 22:32:32 UTC
I'm not sure why the issue has been reopened but it shouldn't be reopened base on unsuccessful verification in 65patch2. The port from the trunk to the 
release65_fixes branch isn't straight forward. If everything is OK in the trunk (I think so, because the issue has been verified already), the status should be 
get back.

kaa, could you please check it?

Comment 12 Sergey Petrov 2009-02-04 09:54:36 UTC
restore status, feel free to reopen or ask me if smth is reproducible or additional actions are required for patch
Comment 13 pgebauer 2009-04-08 14:01:17 UTC
The status whiteboard "65fixes4-candidate" has been removed.
At this time our proactive patches for the NetBeans 6.5.x IDE have concluded.

If you own a Sun service plan contract for NetBeans, you may wish to contact
Sun Service http://www.sun.com/contact/support.jsp to request a fix via the
product defect escalation process.

For more information on purchasing a Sun service plan contract for NetBeans,
refer to the service plan item "Sun Software Service Plans (S3P) for Developers"
in the Sun Service table found on our NetBeans Support Resources
page http://www.netbeans.org/kb/support.html


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo