Bug 154626 - WizardDescriptor.Panel extends Component is illegal
WizardDescriptor.Panel extends Component is illegal
Status: VERIFIED FIXED
Product: serverplugins
Classification: Unclassified
Component: WebLogic
5.x
All All
: P3 (vote)
: 6.x
Assigned To: Thuy.d Nguyen
issues@serverplugins
65fixes3-fixed
:
Depends on:
Blocks: 154624
  Show dependency treegraph
 
Reported: 2008-12-04 15:50 UTC by _ tboudreau
Modified: 2009-03-16 16:33 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description _ tboudreau 2008-12-04 15:50:40 UTC
See details in umbrella issue 154624

java.lang.IllegalStateException: org.netbeans.modules.j2ee.weblogic9.ui.wizard.ServerLocationPanel is both a
WizardDescriptor.Panel and a Component.  This is illegal because Component.isValid() conflicts with Panel.isValid(). 
See umbrella issue 154624 and issues 150223, 134601, 99680 and many others for why this is a Bad Thing.
Comment 1 Vince Kraemer 2008-12-04 15:59:57 UTC

*** This issue has been marked as a duplicate of 154408 ***
Comment 2 Vince Kraemer 2008-12-04 16:12:08 UTC
opps marked as dup too fast...  issue 154408 is for websphere, not weblogic...
Comment 3 Thuy.d Nguyen 2008-12-09 21:08:52 UTC
Refactored to separate WizardDescriptor.Panel from Component (i.e. WizardDescriptor.Panel should not extend Component).

http://hg.netbeans.org/main/rev/f3ce0ab7fb89

Comment 4 Michal Mocnak 2009-03-05 17:17:45 UTC
Verified in nb6.5.1 build 200903050001 on jdk1.5.0_17 (Weblogic 9 and 10.0 can be added only when the ide runs on jdk1.5)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo