Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 154625 - (NB 6.1 escalation) NetBeans Treats xsd/xsl files as Binary when importing into subversion
(NB 6.1 escalation) NetBeans Treats xsd/xsl files as Binary when importing in...
Status: VERIFIED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Subversion
6.x
All All
: P3 (vote)
: 6.x
Assigned To: pslechta
issues@versioncontrol
61fixes5-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 15:41 UTC by pslechta
Modified: 2009-02-10 15:47 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pslechta 2008-12-04 15:41:30 UTC
**************************************************
* This issue is tracked in Bugster as CR 6777516 *
**************************************************

< PATCH REQUEST > 

< PROBLEM DESCRIPTION > 
NetBeans Treats xsd/xsl files as Binary – when importing into subversion

< STEPS TO REPRODUCE > 
1.Create a project in NetBeans.
2.either create an XSD/XSL file or import some into the project in step 1.
3.right click on the project
4.on the pop up menu go to Versioning --> Import into SubVersion Repository
5.When you get to the files to import screen
6.The commit Action for XSDs will be Add as Binary as default

< ESR LEVEL > 
Java CAPS 6
< WORKAROUNDS AND REJECTION REASON > 
The work around is to manually change the Commit Action to Text. 
< DATE REQUIRED & BUSINESS CASE > 
< CUSTOMER INFO > 
Telecom NZ
<CRITERIA > 
Criteria #3: Making development painful – Yes
Criteria #4: Making testing painful (including migration issues) -Yes
*** (#1 of 1): 2008-11-28 05:34:34 CET vince.chau@sun.com
Comment 1 pslechta 2008-12-04 15:43:53 UTC
There is fix for customers that use NB 6.1. The fix is only for NB 6.1, the problem is not reproducible in NB 6.5 (MIME
type registration was rewritten in NB 6.5).

This issue will be delivered as part of 6.1 patch 5.
Comment 2 Tomas Stupka 2008-12-11 09:46:56 UTC
> the problem is not reproducible in NB 6.5
means it is FIXED. doesn't it?
Comment 3 pslechta 2008-12-11 09:51:32 UTC
It is fixed in NB 6.5, but this issue was created for the escalation from the customer that still uses NB 6.1. So the
fix will be provided to the customer for NB 6.1, but the fix will NOT be propagated into NB 6.5, of course.
Comment 4 Tomas Stupka 2008-12-11 10:51:49 UTC
does this also mean that when we fix an issue we keep it open (or reopen them eventually) until they are integrated into
all previous releases they are supposed to be integrated into? And how does this go together with
http://wiki.netbeans.org/IssueLifeCycle#section-IssueLifeCycle-EvaluatingIssues ?

maybe i understand something wrong, but as long an issue is reported against the subversion module in 6.1 and not
reproducible in 6.5 i consider it as fixed or worksforme. 

is there no other channel to keep track about issues like this? It is polluting our dashboard for 7.0 and is a source of
confusion as we have bugcounts to meet for M1 etc.

please, consult this with the dashboard team or keep it at least as incomplete
Comment 5 pslechta 2008-12-11 11:00:27 UTC
Reopening, marking as INCOMPLETE not to confuse developers.
This issue is just for tracking escalation already stored in Bugster, Apollo, and internal JCAPS ecalation db.
Comment 6 rbalada 2008-12-11 11:49:26 UTC
Replacing keywords. The issue report is not incomplete, but does not apply to NB 6.5 and 7.0.
Comment 7 pgebauer 2009-01-13 11:05:50 UTC
The issue has been fixed in the release61_fixes branch

http://hg.netbeans.org/release61_fixes/rev/ceff35501dbc

Comment 8 Peter Pis 2009-01-26 11:37:44 UTC
Verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo