Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 154620 - Highlighting for keywords should be correct for particular DB
Highlighting for keywords should be correct for particular DB
Status: RESOLVED DUPLICATE of bug 76449
Product: db
Classification: Unclassified
Component: SQL Editor
6.x
All All
: P4 (vote)
: TBD
Assigned To: Jiri Rechtacek
issues@db
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-04 15:32 UTC by Roman Mostyka
Modified: 2012-07-10 17:37 UTC (History)
0 users

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Mostyka 2008-12-04 15:32:50 UTC
Now keywords are highlighted for all DBs equally. And equally some DB specific keywords aren't highlighted at all.
It will be better if all keywords for particular DB are highlighted correctly.
Comment 1 David Vancouvering 2008-12-04 16:40:30 UTC
Yes, that would be nice.  It would be nice if we did syntax coloring for all the different DBs too.  It would be nice if
completion worked correctly across all the different DBs :)

Let's just say this is a long-term vision that will take some time to implement...  SQL isn't one language, it's a lot
of languages that look very similar.
Comment 2 Jiri Rechtacek 2009-10-16 14:09:34 UTC
Reassigned to new owner.
Comment 3 matthias42 2012-07-10 17:37:28 UTC

*** This bug has been marked as a duplicate of bug 76449 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo