Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 154529 - cannot run project via script or another application (truss, time, ...)
cannot run project via script or another application (truss, time, ...)
Status: RESOLVED FIXED
Product: cnd
Classification: Unclassified
Component: Project
6.x
All All
: P2 with 1 vote (vote)
: 7.0
Assigned To: igor_nikiforov
issues@cnd
:
: 73658 172524 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-03 20:59 UTC by Thomas Preisler
Modified: 2010-12-09 14:48 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Preisler 2008-12-03 20:59:58 UTC
Sometime it is necessary/desired to run the project from a script or via another application. Examples are mpi <executable>, truss executable>, time executable> but this is currently not possible.

Suggested enhancement:

Add a new property to Run category called "Run Command" with the default value ${BuildOutput}. The users can then prepend mpi, time, truss or what ever 
they want to the run command and running the project should then run the Run Command instead of build output.
Comment 1 Thomas Preisler 2009-11-17 11:22:50 UTC
*** Bug 73658 has been marked as a duplicate of this bug. ***
Comment 2 Alexey Vladykin 2010-05-21 08:00:57 UTC
*** Bug 172524 has been marked as a duplicate of this bug. ***
Comment 3 igor_nikiforov 2010-12-09 10:33:57 UTC
Here is changeset of initial implementation:
  http://hg.netbeans.org/cnd-main/rev/638bf36c3e8d

Note, that you need to turn profiling (gizmo) off if you are going to user commands chains, like this: /usr/bin/time ${OUTPUT_PATH}.
Comment 4 igor_nikiforov 2010-12-09 14:48:33 UTC
The final fix changeset is:
  http://hg.netbeans.org/cnd-main/rev/c5711341bfa7

Now profiling will be turned off automatically. Also issue with remote run is resolved.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo