Bug 154508 - [codehaus] Enhance editor tab for pom.xml files to have ${artifactId} (similar to how ant scripts are represented)
[codehaus] Enhance editor tab for pom.xml files to have ${artifactId} (simila...
Status: VERIFIED FIXED
Product: projects
Classification: Unclassified
Component: Maven
6.x
All All
: P2 with 4 votes (vote)
: 7.0
Assigned To: Jesse Glick
issues@platform
:
: 168902 (view as bug list)
Depends on: 195914
Blocks: 178090
  Show dependency treegraph
 
Reported: 2008-12-03 16:29 UTC by Jaromir Uhrik
Modified: 2011-02-28 15:19 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jaromir Uhrik 2008-12-03 16:29:52 UTC
This issue was originally reported by zac heismann in 11/Sep/08 at codehaus.org - see more details at
http://jira.codehaus.org/browse/MEVENIDE-668
Environment: Windows XP, Netbeans 6.1, Mevenide 3.1.4, java 6 update 10 beta

===========
Description:
===========
I have a hard time distinguishing between pom files, enhancing the editor tab name for pom files to show their
${artifactId} property would provide the ability to distinguish between multiple pom files.
Hopefully my description is clear. I've attached a gif that gives an example of what I'm talking about.

----------------------------------------------
Comment by Milos Kleint [ 12/Sep/08 02:04 AM ]
----------------------------------------------
I've investigated this before. Unfortunately adding the text in the header requires a LOT of boilerplate code to be
added and maintained. Therefore I haven't gone this way so far.
Comment 1 Jaromir Uhrik 2008-12-03 16:30:36 UTC
...I am linking the following file which resides in Jira system:
http://jira.codehaus.org/secure/attachment/36987/AntScriptAndPomsInNetbeansEditor.gif
Comment 2 Milos Kleint 2009-07-22 10:07:06 UTC
*** Issue 168902 has been marked as a duplicate of this issue. ***
Comment 3 bobuse 2009-10-06 13:58:51 UTC
It's a shame that maven projects can't be confortably edited. Last releases of NB brings a lot of powerfull feature for
working with Maven projects, but the browsing through the pom.xml opened is always a pain.

Milos, you said that it is hard, I can understand as I had tried to look (quickly) to the code. If it is so hard, maybe
tab management in the NB platform should be reconsidered.
Could you give some more details on the blocking things ? Or how it is achieved for build.xml ant files, and different
for pom.xml files ?

Thank you a lot.
Comment 4 Milos Kleint 2009-10-06 14:02:53 UTC
ant build files have their own data loader, data object and multiple other classes that need to be maintained and kept
in sync with the xml editor generic data loader & co. That sounds like a too high price to me for having an editor tab
annotation. 
Comment 5 pekarna 2010-01-14 07:54:51 UTC
I agree with comment #3. I disagree with comment #4.
Much of the Java world is moving to Maven. This will will make developement a lot, LOT easier. Having 8 tabs saying "pom.xml" is really not much helping.

If not ${artifactId}, could at least the containing dir name be shown? Even if it would need an ugly if-hack...
Comment 6 Jesse Glick 2010-01-14 08:23:52 UTC
(In reply to comment #5)
> If not ${artifactId}, could at least the containing dir name be shown? Even if
> it would need an ugly if-hack...

See other blockers of bug #178090. But ${artifactId} might be more useful in the case of pom.xml. For example, hudson/trunk/main/test/pom.xml has ${artifactId} = 'hudson-test-harness', which is compact but descriptive, whereas the dir name 'test' is not distinctive.
Comment 7 Antonin Nebuzelsky 2010-07-30 14:38:22 UTC
Rather a P2 enhancement than a P4 defect.
Comment 8 heismann 2010-10-01 21:46:25 UTC
Any idea if this is going to be completed for 6.10?
Comment 9 Jesse Glick 2010-10-04 20:14:28 UTC
core-main #5a389672bb91
Comment 10 Quality Engineering 2010-10-06 03:19:10 UTC
Integrated into 'main-golden', will be available in build *201010060000* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/5a389672bb91
User: Jesse Glick <jglick@netbeans.org>
Log: #154508: [codehaus] Enhance editor tab for pom.xml files to have ${artifactId} (similar to how ant scripts are represented)
Comment 11 pekarna 2011-02-17 18:26:24 UTC
Works in NetBeans IDE Build 201102160501.
Good work, thanks!

Now only if Bug 194773 and Bug 178682 were done and I'd be completely happy regarding my most often pom.xml use cases not yet covered by NetBeans.
Comment 12 Jesse Glick 2011-02-17 21:59:56 UTC
Feel free to verify bugs you can confirm are fixed as expected.
Comment 13 heismann 2011-02-17 22:11:38 UTC
Works as expected.  Thanks for implementing this, it is very helpful.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo