Bug 154408 - accidental double override of isValid
accidental double override of isValid
Status: VERIFIED FIXED
Product: serverplugins
Classification: Unclassified
Component: WebSphere
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Thuy.d Nguyen
issues@serverplugins
65fixes3-fixed
:
: 154627 155409 159010 (view as bug list)
Depends on:
Blocks: 154624
  Show dependency treegraph
 
Reported: 2008-12-03 00:51 UTC by Vince Kraemer
Modified: 2009-04-03 03:53 UTC (History)
13 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (5.25 KB, text/plain)
2009-03-26 13:01 UTC, rajivderas
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Vince Kraemer 2008-12-03 00:51:51 UTC
causes issue on JDK 7...

See the advice from Tim B. in issue 150223 about WizardDescriptor.Panel and Components...

ServerLocationPanel.java violates that sound advice and gets hit by NPE's when the IDE is run under jdk 7 b40...
Comment 1 Petr Hejl 2008-12-04 15:55:35 UTC
*** Issue 154627 has been marked as a duplicate of this issue. ***
Comment 2 Vince Kraemer 2008-12-04 15:59:56 UTC
*** Issue 154626 has been marked as a duplicate of this issue. ***
Comment 3 Thuy.d Nguyen 2008-12-09 21:03:10 UTC
Refactored to separate WizardDescriptor.Panel from Component (i.e. WizardDescriptor.Panel should not extend Component).

http://hg.netbeans.org/main/rev/14a81c6c342b
Comment 4 Vince Kraemer 2008-12-14 17:19:52 UTC
*** Issue 155409 has been marked as a duplicate of this issue. ***
Comment 5 Vince Kraemer 2009-02-06 06:22:42 UTC
try using jdk 6 update 11 or older.
Comment 6 Vince Kraemer 2009-02-23 20:39:48 UTC
*** Issue 159010 has been marked as a duplicate of this issue. ***
Comment 7 Michal Mocnak 2009-03-05 18:32:07 UTC
Verified
Comment 8 rajivderas 2009-03-26 13:01:42 UTC
Build: NetBeans IDE 6.5 (Build 200811100001)
VM: OpenJDK Client VM, 14.0-b10, Java(TM) SE Runtime Environment, 1.6.0_14-ea-b01
OS: Windows XP, 5.1, x86

User Comments: 


Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.j2ee.websphere6.ui.wizard.ServerLocationPanel.isValid(ServerLocationPanel.java:156)
        at java.awt.Component.invalidateIfValid(Component.java:2744)
        at java.awt.Component.setLocale(Component.java:1814)
        at javax.swing.JComponent.<init>(JComponent.java:595)
        at javax.swing.JPanel.<init>(JPanel.java:65)
        at javax.swing.JPanel.<init>(JPanel.java:92)
Comment 9 rajivderas 2009-03-26 13:01:52 UTC
Created attachment 78900 [details]
stacktrace


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo