Bug 15440 - IOException during deserialization of OutputTabTerm
IOException during deserialization of OutputTabTerm
Status: CLOSED DUPLICATE of bug 15703
Product: cnd
Classification: Unclassified
Component: Terminalemulator
3.x
Sun SunOS
: P3 (vote)
: 6.x
Assigned To: akemr
ivan
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2001-09-13 12:46 UTC by anovak
Modified: 2008-12-23 08:22 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
the exceptions (6.03 KB, text/plain)
2001-09-13 12:48 UTC, anovak
Details

Note You need to log in before you can comment on or make changes to this bug.
Description anovak 2001-09-13 12:46:14 UTC
An IOException is thrown when a non stdout OutputTabTerm is deserialized. In
such a case OutputTabTerm$Replace.readResolve returns null, which causes that
XMLSettingsSupport falls back into an attempt to create OutputTabTerm through
public default constructor, which is not present.

Steps how to reproduce (likely):
Start the ide, compile/exec some class, shutdown and start again.
Comment 1 anovak 2001-09-13 12:48:12 UTC
Created attachment 2528 [details]
the exceptions
Comment 2 akemr 2001-09-21 13:17:45 UTC

*** This issue has been marked as a duplicate of 15703 ***
Comment 3 Quality Engineering 2003-07-01 16:03:02 UTC
Resolved for 3.4.x or earlier, no new info since then -> verified.

Comment 4 Quality Engineering 2003-07-01 16:40:15 UTC
Resolved for 3.4.x or earlier, no new info since then -> closing.
Comment 5 Quality Engineering 2008-12-23 08:22:52 UTC
moving terminal emulator issues to terminalemulator component.
To see the correct version and target milestone of this issue look at Issue
Activity table.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo