Bug 154292 - Editor stops responding to certain keys
Editor stops responding to certain keys
Status: RESOLVED WORKSFORME
Product: editor
Classification: Unclassified
Component: Key bindings
6.x
PC Windows XP
: P3 (vote)
: 6.x
Assigned To: issues@editor
issues@editor
: FOCUS, RANDOM
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-01 19:32 UTC by jirka_x1
Modified: 2009-05-12 13:51 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot showing the gray line appears between the folding marks and the text (63.04 KB, text/plain)
2008-12-01 19:33 UTC, jirka_x1
Details
ThreadDump (via StackTrace) (17.26 KB, text/plain)
2008-12-09 22:08 UTC, jirka_x1
Details
messages.log - there are some exceptions, not sure if they are related to the issue (38.62 KB, text/plain)
2008-12-09 22:10 UTC, jirka_x1
Details
Annother message.log when the problem happened again (62.38 KB, text/plain)
2008-12-15 02:15 UTC, jirka_x1
Details
Annother thread dump when the problem happened again (18.02 KB, text/plain)
2008-12-15 02:18 UTC, jirka_x1
Details
The original picture, this time with correct mimetype (63.04 KB, image/jpeg)
2009-01-06 10:25 UTC, Vitezslav Stejskal
Details
zipped uigestures as requested (16.76 KB, application/x-compressed)
2009-01-09 16:03 UTC, jirka_x1
Details
message log (from the same incident as uigestures above) (28.08 KB, text/plain)
2009-01-09 16:05 UTC, jirka_x1
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jirka_x1 2008-12-01 19:32:37 UTC
Time to time, the editor starts to behave weird: a gray line appears between the folding marks (see attachment) and the
text and certain keys do not work (e.g. Backspace) or work differently (arrows don't move through the text but scroll
the window). Closing all documents and reopening them fixes the problem (for a while, restarting netbeans "fixes" it for
a longer time).


I am running NB on jdk1.6.0_02
Comment 1 jirka_x1 2008-12-01 19:33:26 UTC
Created attachment 74363 [details]
Screenshot showing the gray line appears between the folding marks and the text
Comment 2 Vitezslav Stejskal 2008-12-02 10:31:10 UTC
The gray line is where normally diff-sidebar is. Could you attach here your log file; it's in
<userdir>/var/log/messages.log. Thanks
Comment 3 jirka_x1 2008-12-09 22:08:00 UTC
Created attachment 74766 [details]
ThreadDump (via StackTrace)
Comment 4 jirka_x1 2008-12-09 22:10:41 UTC
Created attachment 74768 [details]
messages.log - there are some exceptions, not sure if they are related to the issue
Comment 5 jirka_x1 2008-12-15 02:15:22 UTC
Created attachment 74939 [details]
Annother message.log when the problem happened again
Comment 6 jirka_x1 2008-12-15 02:18:12 UTC
Created attachment 74940 [details]
Annother thread dump when the problem happened again
Comment 7 jirka_x1 2009-01-05 15:21:42 UTC
Is there anything else I can do to help this getting fixed? It happens every-day, some times several times. SHould it
help if I post more logs/dumps?
Comment 8 jirka_x1 2009-01-05 15:25:33 UTC
Priority to P2 per http://wiki.netbeans.org/BugPriorityGuidelines.
Comment 9 Vitezslav Stejskal 2009-01-06 10:23:55 UTC
Hi, I have absolutely no idea what's wrong, but as I said the gray bar is where normally the diff sidebar resides. So,
if this is somehow related to the diff sidebar or the version control plugin for your VCS it could help to disable the
diff sidebar (eg. uncheck View -> Show Diff Sidebar). If disabling it eliminates the problem we can track it down
further looking at what's wrong with your VCS integration.

There are exceptions in the log files, but they don't seem to be related to the editor - some of them were from Junit
plugin, various others complained about unparsable build.xml and inaccessible utils.jar (probably something wrong with
your project setup, but you might have already fixed that). 
Comment 10 Vitezslav Stejskal 2009-01-06 10:25:06 UTC
Created attachment 75479 [details]
The original picture, this time with correct mimetype
Comment 11 jirka_x1 2009-01-07 04:12:40 UTC
Disabling the side bar does not help if it is done after the problem occurs. I will see if it prevents it from occurring. 

Yes, those exceptions are not a problem (I moved the projects around, thus the project dependency problems and I am
using ant to build non-java projects, hence the unparsable build.xml). 

Is it possible to read something from the dumps? Would it make sense if I collected dumps/logs each time it happens and
posted a bunch of them? Or any other way to provide some useful info?
Comment 12 Vitezslav Stejskal 2009-01-07 15:40:48 UTC
Threaddumps are not of much use, because the IDE is not frozen (in deadlock) and so they show no activity. The logs are
more useful to see if there are any exceptions that could cause the problem. There is also the
<ide-userdir>/var/log/uiguestures file, which shows actions that have been done in the IDE. Next time this happens
please attach both the log and the uiguestures file. Hopefully we will be able to see what exactly happened in the IDE
before it got corrupted. Thanks
Comment 13 jirka_x1 2009-01-09 15:55:46 UTC
So it does happen even with the diff-sidebar disabled.

There are few more things that are unusual except the keys and diff-sidebar:
- Edit | Find/Replace commands in the main menu are grayed (Ctrl+F/H does not work either)
- the editor context menu does not work
- suggestion side bar is not there (but the yellow underlines in the code and their tooltips do work)
- line numbers on the side are not there
- Alt Insert for code insert does not work 
- Ctrl+Click for navigating to the source does work (and if the file with source has not been opened and is open, that
particular editor tab works normally!)
Comment 14 jirka_x1 2009-01-09 16:03:46 UTC
Created attachment 75640 [details]
zipped uigestures as requested
Comment 15 jirka_x1 2009-01-09 16:05:45 UTC
Created attachment 75641 [details]
message log (from the same incident as uigestures above)
Comment 16 _ wadechandler 2009-01-10 19:48:23 UTC
I thought I was experiencing 119617, but it seems I'm mostly experiencing this issue. I added some comments etc on the
other issue. Anyways, the next time this happens I'll also attach a screen shot where the projects view JTree has a long
vertical gap where the Nodes are. Seems someone may be accessing some Swing logic from the wrong thread or something and
there is a concurrency issue taking place. I'm not sure yet, but something is definitely messing up more than one place.
The cause may very well be related to 119617 just the same.
Comment 17 _ wadechandler 2009-02-04 16:17:22 UTC
I wrote the following in the other issue. It seems they are both related, at least in my experience:
More information. It happened again, but this time I couldn't even get a cursor in the editor. This was on a local
laptop running Windows XP SP3. This was on a project using Mercurial. I was working on
https://hg.netbeans.org/platformx. I had build scripts and some Java files opened. I changed them in a text editor,
TextPad, outside of the IDE; I was checking on some things, opened them, and just worked on them there...spontaneous I
guess. Anyways, I changed back to NB, tried to click in the editor, and nothing. I had to close the files and reopen them. 

Is anyone else noticing this as being their issue? Are you editing files outside of the IDE and then switching back and
roughly then it is losing focus? Every time this or the other issue has happened to me I have been using something else
to edit files and switching between the other editor and NB. This has happened to me in Ant, Java, and JSP files now.

Too, this doesn't happen always. It is sporadic. I can edit files quite regularly at times back and forth, and it
doesn't happen. Other days it happens a whole lot. In all cases it seems to have been when changing files outside the
IDE. Maybe some of you others have not been using another editor, but maybe you have been using svn or hg to update
files and ones you have opened in the editor are reloaded perhaps? Anyways, I'm just noticing this as a pattern from my
end on more than one system now.
Comment 18 jirka_x1 2009-02-09 20:39:15 UTC
Yes, I often edit files outside of IDE (The reason is that NB is really bad for having several files with the same name
- it does not display the full path anywhere so it always takes forever to find the right file). I switch there and
back. I also use TortoiseSvn, because unfortunately the svn support in NB is not that great.

I will try to see if it happens when moving back to the IDE. 
Comment 19 jirka_x1 2009-02-10 14:39:21 UTC
So no. Yesterday it happened without me editing anything outside. But it does seem that it always happens when switching
back to the document (regardless whether from some other app or some other editor tab within NB), I don't think it ever
happened in the middle of editing a document.
Comment 20 Vitezslav Stejskal 2009-02-16 12:26:24 UTC
Any chance that you guys are using VNC? See issue #156648 that complains about the same symptoms, but in relation to
accepting/closing VNC connections.
Comment 21 _ wadechandler 2009-02-16 14:52:09 UTC
On one system I use GoToMyPC, but none of my others use a VNC related technology. It has happened both ways. Definitely
a problem while switching focus it seems. This from one application to another or tabs in the editor. I notice that when
I do this from another application it sometimes will mess up all the ones I have opened and not just the one with the
cursor. All times it is related to switching focus though for me I have only ever seen it occur while switching from one
application to the next.
Comment 22 jirka_x1 2009-02-24 17:11:31 UTC
No I am not using VNC.
Comment 23 Vitezslav Stejskal 2009-04-10 09:38:22 UTC
Is this still happening in recent dev builds or 6.7M3? This is one of those mysterious defects that for sure are very
annoying when they happen, but they only happen randomly and only to a few people. Which makes them extremely hard to
investigate and fix. If this is no longer troubling you guys please close this issue. I'm leaving it open as P3 for
others to add their comments, should there be more people experiencing the same problem. But realistically I don't think
we can fix this without having a reproducible testcase.
Comment 24 Jiri Prox 2009-05-12 13:51:51 UTC
There are no new reports from 6.7m3 and 6.7beta, so I'm closing this issue as works for me for now, if it still happens,
please reopen it.
Thanks


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo