Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 154280 - Libraries are not refreshed when provider is installed/uninstalled
Libraries are not refreshed when provider is installed/uninstalled
Status: VERIFIED FIXED
Product: projects
Classification: Unclassified
Component: Libraries
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Tomas Zezula
issues@projects
65fixes2-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-12-01 16:45 UTC by Jaroslav Tulach
Modified: 2009-02-19 22:56 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Fix and test (3.78 KB, patch)
2008-12-01 16:45 UTC, Jaroslav Tulach
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Jaroslav Tulach 2008-12-01 16:45:33 UTC
When working on http://wiki.netbeans.org/FitnessForever I found out that often enabling a set of modules (like web 
cluster) and then creating a project, can lead to project reporting broken references. I've tracked this down to a 
race condition between project.library's LibraryStorage refresh and LibraryTypeRegistry refresh. If the order is 
refresh LibraryStorage first and then refresh LibraryTypeRegistry, things get broken, the system is not aware of all 
registered libraries.

I guess one possible fix is to listen on LibraryTypeRegistry and refresh the storage in case the type registry changes 
its content.
Comment 1 Jaroslav Tulach 2008-12-01 16:45:57 UTC
Created attachment 74353 [details]
Fix and test
Comment 2 Tomas Zezula 2008-12-01 16:48:20 UTC
Seems fine to me, feel free to integrate.
Comment 3 Jaroslav Tulach 2008-12-01 16:57:56 UTC
core-main#bf7e064d5d94
Comment 4 Quality Engineering 2008-12-02 05:58:20 UTC
Integrated into 'main-golden', will be available in build *200812020201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/bf7e064d5d94
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #154280: Libraries are not refreshed when provider is installed/uninstalled. Reviewed by tzezula@netbeans.org
Comment 5 Quality Engineering 2008-12-03 05:57:46 UTC
Integrated into 'main-golden', will be available in build *200812030201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/efc54c351914
User: Jaroslav Tulach <jtulach@netbeans.org>
Log: #154280: Jesse correctly pointed out that I have forgotten to commit the new test file. Thanks.
Comment 6 Tomas Danek 2009-01-12 15:40:28 UTC
no regression caused by this was found, marking verified.
Comment 7 pgebauer 2009-01-14 20:53:56 UTC
The fix has been ported into the release65_fixes repository.

http://hg.netbeans.org/release65_fixes/rev/bd5803e237f4
Comment 8 Tomas Danek 2009-01-19 11:05:23 UTC
fixes problems with libraries deactivation/activation for 6.5 and no regression found. verified in 6.5 patch 2.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo