Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 154055 - CC for class members doesn't work correctly on last line
CC for class members doesn't work correctly on last line
Status: VERIFIED FIXED
Product: php
Classification: Unclassified
Component: Editor
6.x
All All
: P2 (vote)
: 6.x
Assigned To: Tomasz Slota
issues@php
65fixes2-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-28 00:10 UTC by Petr Pisl
Modified: 2009-02-19 22:52 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Petr Pisl 2008-11-28 00:10:45 UTC
Have a simple file without the close PHP delimiter:

<?php

class Book {
    public $title;
    public $author;
}

$book = new Book();
$book->

If the $book-> is on the last line, then the cc doesn't show class members. If you enter new line after $book-> then the
cc work correctly.
Comment 1 Tomasz Slota 2008-11-28 15:46:16 UTC
It works fine for me with the daily build, it looks like the conditions to reproduce are more complex. Pls verify
Comment 2 Mikhail Matveev 2008-11-28 18:34:38 UTC
It works for me too. 
As I remember, similar bug has been filed sometime ago, but has been fixed...
Comment 3 Petr Pisl 2008-12-01 15:12:56 UTC
Tomasz, Mikhail: the bug is not fixed. Have you see $title and $author in cc on the last line after $book-> ? I don't
see it in the Monday's build, so I don't believe that this is already fixed => reopening. 
Comment 4 Tomasz Slota 2008-12-03 11:40:19 UTC
fixed & unit tested
http://hg.netbeans.org/main/rev/08d1214027a4
Comment 5 Quality Engineering 2008-12-05 06:22:15 UTC
Integrated into 'main-golden', will be available in build *200812050201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/08d1214027a4
User: Tomasz Slota <tslota@netbeans.org>
Log: #154055: CC for class members doesn't work correctly on last line
Comment 6 Mikhail Matveev 2008-12-23 14:20:29 UTC
Verified
Comment 7 jinb 2009-01-14 15:38:07 UTC
fix backported into release65_fixes branch
http://hg.netbeans.org/release65_fixes/rev/786c3d7b7aae
Comment 8 Victoria Zhukovskaya 2009-01-21 13:34:31 UTC
Verified in 65patch2


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo