Bug 153893 - EQ frozen trying to use Versioning menu
EQ frozen trying to use Versioning menu
Status: RESOLVED FIXED
Product: apisupport
Classification: Unclassified
Component: Maven
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Milos Kleint
issues@platform
: THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-25 21:14 UTC by Jesse Glick
Modified: 2008-11-26 06:42 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Some thread dumps (121.61 KB, text/plain)
2008-11-25 21:15 UTC, Jesse Glick
Details
Another freeze of a couple of minutes after restarting IDE and just selecting project node (34.45 KB, text/plain)
2008-11-25 21:18 UTC, Jesse Glick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jesse Glick 2008-11-25 21:14:26 UTC
I had selected a couple of Maven projects (both POM packaging, I believe), and tried to post the Versioning menu. The
IDE froze with 100% CPU.
Comment 1 Jesse Glick 2008-11-25 21:15:48 UTC
Created attachment 74145 [details]
Some thread dumps
Comment 2 Jesse Glick 2008-11-25 21:18:36 UTC
Created attachment 74146 [details]
Another freeze of a couple of minutes after restarting IDE and just selecting project node
Comment 3 Jesse Glick 2008-11-25 21:39:29 UTC
This was with the older Mevenide 3.1.3. I just upgraded to 4.1, I guess being built daily, which seems to be better.
Comment 4 Milos Kleint 2008-11-26 06:42:51 UTC
the problem was caused by 
	at org.codehaus.mevenide.netbeans.NbMavenProject.getLookup(NbMavenProject.java:492)
	- locked <0x73aa5880> (a org.codehaus.mevenide.netbeans.NbMavenProject)
	at org.netbeans.modules.projectapi.ProjectSharabilityQuery.getSharability(ProjectSharabilityQuery.java:67)
	at org.netbeans.api.queries.SharabilityQuery.getSharability(SharabilityQuery.java:110)

triggering project loading, lookup composition and the maven's project instance loading, not for the actual project
being opened but all the subfolders (which I assume were all projects as well in your case, most of them probably not
loaded before)

3.1.x is rather old (as nb 6.1), the changes i've done in 6.5 timeframe include avoiding to compose the complete project
lookup if only ProjectInformation and SharabilityQueryImplementation are being looked up. Also the maven's project
loaded got faster by a few tweak, most visible for deep structures of projects (many parents and modules).

I consider it fixed, please reopen if you disagree while using 4.1 of maven support.

I've fixed in in 


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo