Bug 153847 - Deadlock during commit validation
Deadlock during commit validation
Status: RESOLVED DUPLICATE of bug 83941
Product: platform
Classification: Unclassified
Component: Window System
6.x
Macintosh All
: P1 (vote)
: TBD
Assigned To: Jaroslav Tulach
issues@platform
jdk_bug_4913324
: RANDOM, TEST, THREAD
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-25 12:16 UTC by Tomas Zezula
Modified: 2009-02-19 22:53 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
deadlock (8.08 KB, text/plain)
2008-11-25 12:18 UTC, Tomas Zezula
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tomas Zezula 2008-11-25 12:17:02 UTC
Deadlock happens during commit validation, see attached thread dump.
Comment 1 Tomas Zezula 2008-11-25 12:18:51 UTC
Created attachment 74128 [details]
deadlock
Comment 2 David Simonek 2008-11-25 12:38:27 UTC
I see deadlock between TimableEventQueue x java.awt.EventQueue
Passing to jtulach, please reassign if I'm wrong.
Comment 3 Jaroslav Tulach 2008-11-26 15:06:24 UTC
Jelly's own EventQueue seems to be involved as well.
Comment 4 Lukas Hasik 2008-12-04 10:39:28 UTC
could you look at this bug, please? It is P1. And it is reported from commit validation that should pass in 100%. P1
problems should be evaluated and addressed asap. Thank you
Comment 5 Jiri Skrivanek 2008-12-10 14:03:25 UTC
It is a JDK bug 4913324. I think we can't work it around.

http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=4913324

*** This issue has been marked as a duplicate of 83941 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo