Bug 153522 - NB hangs after trying to "Add Platform"
NB hangs after trying to "Add Platform"
Status: RESOLVED WONTFIX
Product: platform
Classification: Unclassified
Component: Window System
6.x
All Windows XP
: P2 (vote)
: TBD
Assigned To: rmichalsky
issues@platform
jdk_bug_5050516
: THREAD
: 153592 162714 172083 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-20 10:46 UTC by dlpa
Modified: 2009-09-14 15:24 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
jstack log (20.73 KB, text/plain)
2008-11-20 10:47 UTC, dlpa
Details
sta (18.01 KB, text/plain)
2008-12-09 13:22 UTC, rmichalsky
Details
stacktrace 2 (17.20 KB, text/plain)
2008-12-09 13:22 UTC, rmichalsky
Details

Note You need to log in before you can comment on or make changes to this bug.
Description dlpa 2008-11-20 10:46:44 UTC
NB hangs after "Add Platform" button is pressed.
See the jstack log.
Comment 1 dlpa 2008-11-20 10:47:30 UTC
Created attachment 73943 [details]
jstack log
Comment 2 dlpa 2008-11-20 10:49:34 UTC
Product Version: NetBeans IDE 6.5 (Build 200811100001)
Java: 1.6.0_10; Java HotSpot(TM) Client VM 11.0-b15
System: Windows XP version 5.1 running on x86; Cp1250; pl_PL (nb)
Userdir: C:\Documents and Settings\Robert\.netbeans\6.5
Comment 3 Lukas Hasik 2008-11-21 10:04:55 UTC
is it reproducible?
Comment 4 rmichalsky 2008-11-21 17:46:07 UTC
According the stacktrace this is JDK issue with File Chooser: 
http://forums.sun.com/thread.jspa?threadID=5309960
http://bugs.sun.com/bugdatabase/view_bug.do?bug_id=5050516

The workaround is allegedly to clean up desktop shortcuts in XP :).
Comment 5 dlpa 2008-11-21 19:16:44 UTC
I've sometimes problem with NB (while accesses filesystem) and it's probably because of problems you have mentioned.
Thanks.
Comment 6 rmichalsky 2008-12-09 13:20:34 UTC
*** Issue 153592 has been marked as a duplicate of this issue. ***
Comment 7 rmichalsky 2008-12-09 13:20:50 UTC
A consequence of JDK bug, but there should be a workaround, something has changed that triggers this bug much more often
than before. Reproducible even when all modules are already loaded, so the workaround will be more complicated than
disable "Add Platform" button until module list is loaded. 

Adding some more stack traces.
Comment 8 rmichalsky 2008-12-09 13:22:05 UTC
Created attachment 74745 [details]
sta
Comment 9 rmichalsky 2008-12-09 13:22:42 UTC
Created attachment 74746 [details]
stacktrace 2
Comment 10 _ wadechandler 2008-12-09 17:21:06 UTC
@rmichalsky from Issue 153592 Yes, I was using XP when I experienced this problem. I believe. It only happens to me
however when the modules have not loaded and the "Please wait..." or "Modules loading..." or what ever message is on the
screen for an existing platform in the dialog. Which ever one is by default loading and searching for modules. If that
is up and I click on the "Add Platform" button it hangs.
Comment 11 rmichalsky 2008-12-11 12:56:50 UTC
Happens with older versions of NetBeans as well.

Workaround is to upgrade to JDK 6u10 or later or downgrade to JDK 5.
Comment 12 joro 2009-02-05 11:07:14 UTC
I've had this issue reproducible even with JDK 1.6.0-12 on german Win XP.
My IDE was forced to english locale in <Netbeansfolder>\etc\netbeans.conf with 
netbeans_default_options="--locale en:EN ...

The problem disappeared when I removed this and started the IDE with default german locale.
Perhaps JFileChooser on Windows machines uses some kind of localization to find the system user directory?
Comment 13 joro 2009-02-05 13:39:39 UTC
Some more info on this topic:
everything works fine (even with forced english locale) if I first open a FileChooser with 'Open Project' 
and cancel this action. 
When I then go to 'Tools | Netbeans Platforms' and press 'Add Platform...' the FileChooser comes up without problem.
Comment 14 Vince Kraemer 2009-04-16 16:44:24 UTC
*** Issue 162714 has been marked as a duplicate of this issue. ***
Comment 15 rmichalsky 2009-09-14 15:24:28 UTC
*** Issue 172083 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo