Bug 153417 - reflect.UndeclaredThrowableException at $Proxy15.actionPerformed
reflect.UndeclaredThrowableException at $Proxy15.actionPerformed
Status: CLOSED FIXED
Product: javame
Classification: Unclassified
Component: -- Other --
6.x
PC Windows XP
: P2 with 1 vote (vote)
: 6.x
Assigned To: _ tboudreau
issues@mobility
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT, 65fixes3-verified
:
: 159009 159867 159872 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-18 19:41 UTC by lifej15
Modified: 2009-10-05 09:39 UTC (History)
38 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
i don't know used (56.26 KB, text/plain)
2009-06-15 10:14 UTC, oki
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lifej15 2008-11-18 19:41:33 UTC
Build: NetBeans IDE 6.1 (Build 200805300101)
VM: Java HotSpot(TM) Client VM, 14.0-b05, Java(TM) SE Runtime Environment, 1.7.0-ea-b36
OS: Linux, 2.6.24-19-generic, i386
User comments: 
STACKTRACE: (first 10 lines)
java.lang.reflect.UndeclaredThrowableException
        at $Proxy.actionPerformed(.java:0)
        at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:2015)
        at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2338)
        at javax.swing.DefaultButtonModel.fireActionPerformed(DefaultButtonModel.java:404)
        at javax.swing.DefaultButtonModel.setPressed(DefaultButtonModel.java:259)
        at javax.swing.plaf.basic.BasicButtonListener.mouseReleased(BasicButtonListener.java:253)
        at java.awt.Component.processMouseEvent(Component.java:6218)
        at javax.swing.JComponent.processMouseEvent(JComponent.java:3293)
        at java.awt.Component.processEvent(Component.java:5983)
        at java.awt.Container.processEvent(Container.java:2046)
Comment 1 Lukas Hasik 2008-11-19 09:50:31 UTC
java.lang.NullPointerException
        at java.util.HashSet.(HashSet.java:116)
        at
org.netbeans.modules.mobility.project.ui.wizard.ConfigurationsSelectionPanelGUI.isValid(ConfigurationsSelectionPanelGUI.java:191)
        at java.awt.Component.invalidateIfValid(Component.java:2711)
 
Comment 2 Karol Harezlak 2008-11-19 10:39:47 UTC
Reassigning it has something to do woth project module.
Comment 3 Petr Suchomel 2008-12-01 15:55:07 UTC
May be already fixed in 6.5 .. not sure.
Comment 4 _ tboudreau 2008-12-02 18:01:58 UTC
This happened because ConfigurationsSelectionPanelGUI was accidentally overriding Component.isValid().  I noticed this a
while ago and changed the method name to valid(), so it will no longer be called from the superclass constructor.
Comment 5 mspprabhu 2009-02-06 06:23:21 UTC
I hav installed NetBeans IDE6.5 with all latest update but still this error occurs
Comment 6 _ tboudreau 2009-02-06 08:07:36 UTC
It will occur in 6.5.  It is fixed in 7.0.  If you would like to try a version of NetBeans which includes the fix, you
can get one at http://bits.netbeans.org/download/trunk/nightly/latest/
Comment 7 chiappone 2009-02-20 04:40:34 UTC
How come only on version 7? This is blocking me from creating a new Java ME project.
Comment 8 jmroman 2009-02-20 08:37:45 UTC
It's even preventing me from testing it to decide on an appropriate tool.

Ten years using forte-netbeans and now I can not work on a wide spread kind of projects with my favorite IDE ! From the
user point of view that's nonsense, although I am sure you have your reasons to make us wait for version 7.0...

Please, could you reconsider this issue?
Comment 9 chiappone 2009-02-20 16:43:23 UTC
I agree.

How am I supposed to use this NetBeans 6.5 IDE if I can't even create a Java ME project to try it on?

Thank you,
Fausto.
Comment 10 chiappone 2009-02-20 16:44:01 UTC
I agree.

How am I supposed to use this NetBeans 6.5 IDE if I can't even create a Java ME project to try it on?

Thank you,
Fausto.
Comment 11 Petr Suchomel 2009-02-20 16:52:57 UTC
What version of JDK you are using? If JDK6u12 please downgrade to u11.
Comment 12 chiappone 2009-02-20 16:59:02 UTC
Yes, JDK6u12. Let me try and get back here.
Comment 13 chiappone 2009-02-20 17:11:39 UTC
I tried with JDK6u10 and it worked for me.

Thank you very much.
Comment 14 Marian Mirilovic 2009-03-05 17:32:32 UTC
*** Issue 159009 has been marked as a duplicate of this issue. ***
Comment 15 Petr Suchomel 2009-03-05 22:27:14 UTC
Fixed in release65_fixes CS bbe117b6eb41
Comment 16 Andrei Chistiakov 2009-03-06 08:55:29 UTC
Verified with NetBeans IDE 6.5.1 (Build 200903060201).
Comment 17 Denis Anisimov 2009-03-12 16:43:13 UTC
*** Issue 159872 has been marked as a duplicate of this issue. ***
Comment 18 Denis Anisimov 2009-03-12 16:43:24 UTC
*** Issue 159867 has been marked as a duplicate of this issue. ***
Comment 19 oki 2009-06-15 10:14:18 UTC
Created attachment 83577 [details]
i don't know used
Comment 20 ravipatel4 2009-06-19 05:20:15 UTC
I have tried to create MIDP application for my mobile.
But while creating new MIDP project I was getting some exception..
I dont know what it is.
Please help me.
Thank you for your time.
Best Regards,
Ravi.
Comment 21 ravipatel4 2009-06-19 05:38:04 UTC
Yes. With Java 1.6 update 10 it is working..
Thank you for information.
Comment 22 ravipatel4 2009-06-19 05:38:41 UTC
Yes. With Java 1.6 update 10 it is working..
Thank you for information.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo