Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 153411 - Doubled unremovable breakpoint annotations
Doubled unremovable breakpoint annotations
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Debugger
6.x
All All
: P2 (vote)
: 6.x
Assigned To: _ gordonp
issues@cnd
65fixes2-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-18 19:03 UTC by Alexander Pepin
Modified: 2009-06-25 10:59 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Patch for IZ 153411 in a release65_fixes based repository (16.61 KB, text/plain)
2009-01-20 22:00 UTC, _ gordonp
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Pepin 2008-11-18 19:03:46 UTC
in build 200811180201
if I try to set a line breakpoint I get doubled unremovable annotations.
Probably it's a bug in the editor infrastructure, please reassign it in this case.
Comment 1 Alexander Pepin 2008-11-25 16:31:03 UTC
Steps to reproduce on Windows:
- create Welcome project
- try to set BP, everything is OK
- go to declaration of 'cout' (iostream)
- try to set BP in "iostream" file, BP appears with a doubled annotation
Result: After that any new BP in welcome.cc or elsewhere gets doubled annotation
Comment 2 _ gordonp 2008-11-26 23:35:57 UTC
Fixed with http://hg.netbeans.org/main/rev/66b17c7ba5ef

The problem was that BreakpointAnnotationProvider.annotate was registering as a DebuggerManagerListener
multiple times, causing multiple breakpoint annotations.
Comment 3 Quality Engineering 2008-11-28 17:18:40 UTC
Integrated into 'main-golden', will be available in build *200811281401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/fc7ed0c9dd42
User: Gordon Prieur <gordonp@netbeans.org>
Log: Fixed IZ #153411  Doubled unremovable breakpoint annotations
Also removed some unused (although not obviously unused) source files.
Comment 4 Alexander Pepin 2008-12-04 18:38:33 UTC
verified in build 20081204
Comment 5 _ gordonp 2009-01-20 22:00:31 UTC
Created attachment 76061 [details]
Patch for IZ 153411 in a release65_fixes based repository
Comment 6 pgebauer 2009-01-21 00:02:59 UTC
This issue is a serious regression for 65patch2. It have to be fixed in 65patch2. The fix has been ported into the release65_fixes repository.

http://hg.netbeans.org/release65_fixes/rev/d8ce2ee65db9
Comment 7 pgebauer 2009-01-21 16:40:24 UTC
The additional change has been ported into the release65_fixes repository.

http://hg.netbeans.org/release65_fixes/rev/76d3d8e5ccaf
Comment 8 Alexander Pepin 2009-01-21 20:35:33 UTC
verified in patch2 (build #59)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo