Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 153407 - V3:Missing JSLT library jar file
V3:Missing JSLT library jar file
Status: VERIFIED FIXED
Product: serverplugins
Classification: Unclassified
Component: GlassFish
6.x
All All
: P2 (vote)
: 6.x
Assigned To: _ pcw
issues@serverplugins
65fixes2-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-18 18:42 UTC by davisn
Modified: 2009-02-19 23:04 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Screen shot (72.10 KB, image/gif)
2008-12-02 09:37 UTC, dpkumar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description davisn 2008-11-18 18:42:57 UTC
The Library Glassfish V3 does not contain the either appserv-jstl.jar or jslt-impl.jar file, as a result when added a
JSLT component to a jsp file, <%@taglib prefix="c" uri="http://java.sun.com/jsp/jstl/core"%> statement is defined as
missing 

Step to Reproduce:
1. Install NB 6.5 RC build
2. Create a web project
3. Open index.jsp file > drap a JSTL component from the Palette to the index file
BUG:
   The error message displays as "The absolute uri: http://java.sun.com/jsp/jstl/core can not be resolved in the web.xml..."
Comment 1 davisn 2008-11-18 19:14:26 UTC
Change bug component
Comment 2 davisn 2008-11-18 21:58:12 UTC
Peter, can we fix this in patch 1? tnk
Comment 3 _ ludo 2008-11-18 22:12:52 UTC
yep, we need this in patch2...
Fix is trivial: add the modules/web/jstl-impl.jar in the libs 

While we are on it, we need to verify *all* the possibll tld files and see what we are missing.
Comment 4 _ ludo 2008-11-18 22:13:22 UTC
sorry, patch1
Comment 5 _ pcw 2008-11-20 21:26:57 UTC
Isn't this a duplicate of issue 152333 (which I previously requested escalation to NB 6.5 patch status)?
Comment 6 Vince Kraemer 2008-11-21 03:19:56 UTC
i think this is a dup of issue 153407...

Davis: I guess you can verify that the fix that is in the trunk addressed this.

You need to verify the other issue, so the fix can be backported into the release65_fixes branch...

Comment 7 davisn 2008-11-21 19:05:38 UTC
Will verify with trunk build
Comment 8 davisn 2008-11-22 01:32:58 UTC
Verify with Netbean IDE Dev today (11/21/08), the problem still occurs,
Comment 9 Vince Kraemer 2008-12-01 21:52:44 UTC
http://hg.netbeans.org/main/rev/936a8a0c57a7
Comment 10 _ pcw 2008-12-01 22:28:29 UTC
Did a bug get filed against GlassFish V3 to fix this jar so it adheres to the rules?

Can the patch be changed to check to see if the jar being added is already in the list (so we future proof against fixed
V3 servers that correctly indicate this jar)?
Comment 11 dpkumar 2008-12-02 09:36:49 UTC
Still able to reproduce this issue in the latest trunk IDE Build 200812011401
Comment 12 dpkumar 2008-12-02 09:37:19 UTC
Created attachment 74382 [details]
Screen shot
Comment 13 Vince Kraemer 2008-12-02 16:07:58 UTC
yes. builds produced before the integration time will still be broken.  please retry with the Dec. 3 build... to account
for time differences.
Comment 14 Vince Kraemer 2008-12-02 16:22:12 UTC
filed issue in GF tracker: https://glassfish.dev.java.net/issues/show_bug.cgi?id=6867
Comment 15 Vince Kraemer 2008-12-04 19:42:39 UTC
I had to start from a clean userdir to get the library to be constructed correctly.

I will see if I can make the change a bit stronger, so it will take effect in situations where the userdir already has a
GF library...
Comment 16 Vince Kraemer 2008-12-04 20:51:49 UTC
I was wrong.

It seems like the trunk build (from hudson http://deadlock.netbeans.org/hudson/job/trunk/4495) has the change but the
dev build available from netbeans.org does not have the fix in it... 

Please try using one of the recent hudson builds...
Comment 17 dpkumar 2008-12-05 04:42:52 UTC
Could you please let me know from where I can download recent Hudson builds.
Comment 18 dpkumar 2008-12-05 05:57:22 UTC
This fix is verified in the latest Hudson build 4500(IDE build 20081205031259)
(http://deadlock.netbeans.org/hudson/job/trunk/4500/artifact/nbbuild/dist/zip/.
Hence changing status to verified
Comment 19 Quality Engineering 2008-12-05 06:22:51 UTC
Integrated into 'main-golden', will be available in build *200812050201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/936a8a0c57a7
User: Vince Kraemer <vkraemer@netbeans.org>
Log: #153407: JSTL taglibs aren't in the classpath
Comment 20 pslechta 2008-12-16 14:10:31 UTC
The fix was ported into release65_fixes repository.

http://hg.netbeans.org/release65_fixes/rev/4a94062f9953
Comment 21 Martin Fousek 2009-01-19 12:50:27 UTC
Verified with NB 6.5 with updates from UC for Patch2.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo