Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 153308 - MinGW/DLL invalid .lib targets, build problem
MinGW/DLL invalid .lib targets, build problem
Status: VERIFIED FIXED
Product: cnd
Classification: Unclassified
Component: Project
6.x
All Windows Vista
: P3 (vote)
: 6.x
Assigned To: Alexey Vladykin
issues@cnd
65fixes2-verified
:
: 154878 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-17 10:26 UTC by Alexey Vladykin
Modified: 2009-02-19 20:29 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Screenshot explaining the problem (217.57 KB, image/png)
2008-11-17 10:27 UTC, Alexey Vladykin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexey Vladykin 2008-11-17 10:26:35 UTC
Reported by Jakub Zawierucha at users@cnd.netbeans.org:

Hello,
 
I have issue with dynamic library build. I use MinGW and NetBeans 6.5 RC2. Every time when my project is updated
NetBeans add new build targets for .lib files whitch are invalid and cause 'make' complains. Problem is illustrated by
screenshot. Did i something wrong with my project or this is a bug ?
 
C:\MinGW\MSYS\bin>make --version
GNU Make 3.81
Copyright (C) 2006  Free Software Foundation, Inc.
This is free software; see the source for copying conditions.
There is NO warranty; not even for MERCHANTABILITY or FITNESS FOR A
PARTICULAR PURPOSE.
 
This program built for i686-pc-msys
Comment 1 Alexey Vladykin 2008-11-17 10:27:29 UTC
Created attachment 73820 [details]
Screenshot explaining the problem
Comment 2 Alexey Vladykin 2008-11-17 10:39:09 UTC
NetBeans adds those targets to tell 'make' to relink the DLL whenever one of the listed *.lib or *.a files change. It is
expected behavior.

However there seems to be a problem with how the absolute paths to *.lib files are written. The error message from
'make' suggests that it does not understand "C\:\MinGW\lib\boost_filesystem-mgw34-mt-1_37.lib" as path to existing file.
The path should be written in some other form.

Could you please, instead of deleting these rules in Makefile, change them a bit and see if 'make' understands them? The
options to try are:
- replace "C\:\MinGW\..." with "C:\MinGW\..." (with backslashes as path separators)
- replace "C\:\MinGW\..." with "C:/MinGW/..." (with forward slashes as path separators)
Comment 3 t3q 2008-11-17 11:16:15 UTC
I've tryed both options that you suggested and both are working for me. DLL is builed with success.

JZ
Comment 4 Thomas Preisler 2008-11-19 04:19:56 UTC
Any issues left?
Comment 5 Thomas Preisler 2008-11-19 04:22:00 UTC
seems fixed
Comment 6 Alexey Vladykin 2008-11-19 14:48:53 UTC
Thomas, issue is not fixed. I don't think that hand-editing the Makefile every time is a fix.
I can take care of this, as I already own somewhat related issue 150099.
Comment 7 Alexey Vladykin 2008-11-28 16:32:30 UTC
Fixed in http://hg.netbeans.org/main/rev/0b947aac9fa9
Paths are now converted to "/drive-letter/dir1/dir2/..." form.
Comment 8 Alexey Vladykin 2008-12-09 07:19:42 UTC
*** Issue 154878 has been marked as a duplicate of this issue. ***
Comment 9 Alexander Pepin 2008-12-15 16:16:18 UTC
verified in build 200812150201
Absolute paths are now converted to "/drive-letter/dir1/dir2/..." form.
Comment 10 Alexander Pepin 2009-01-13 15:18:52 UTC
It would be nice to have the fix in NB 6.5 patch
Comment 11 jinb 2009-01-14 18:59:27 UTC
Cumulative backport of fix of IZ 150099, 153308 in release65_fixes branch:
http://hg.netbeans.org/release65_fixes/rev/3870929f513a
Comment 12 Alexander Pepin 2009-01-19 17:45:01 UTC
verified in patch2


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo