Bug 153270 - NullPointerException at org.netbeans.modules.subversion.Subversion.getClient
NullPointerException at org.netbeans.modules.subversion.Subversion.getClient
Status: RESOLVED DUPLICATE of bug 122411
Product: versioncontrol
Classification: Unclassified
Component: Subversion
6.x
All All
: P3 (vote)
: TBD
Assigned To: issues@versioncontrol
issues@versioncontrol
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-16 09:19 UTC by benbrand
Modified: 2008-11-29 05:27 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (788 bytes, text/plain)
2008-11-16 09:19 UTC, benbrand
Details

Note You need to log in before you can comment on or make changes to this bug.
Description benbrand 2008-11-16 09:19:33 UTC
Build: NetBeans IDE 6.5 RC2 (Build 200810270001)
VM: Java HotSpot(TM) 64-Bit Server VM, 1.6.0_07-b06-57, Java(TM) SE Runtime Environment, 1.6.0_07-b06-153
OS: Mac OS X, 10.5.5, x86_64

User Comments:
benbrand: When reverting a file in my project.

GUEST: Started Netbeans, during loading this exception occurred. Downloaded Netbeans again from www.netbeans.org. Reinstalled Netbeans. And again during starting this exception occurred.

GUEST: cannot open the subversion window. 
I am using collabnet svn

GUEST: cannot open the subversion window. 
I am using collabnet svn

benbrand: When reverting a file in my project.



Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.subversion.Subversion.getClient(Subversion.java:211)
        at org.netbeans.modules.subversion.Subversion.getClient(Subversion.java:244)
        at org.netbeans.modules.subversion.ui.status.StatusAction.executeStatus(StatusAction.java:104)
        at org.netbeans.modules.subversion.ui.status.VersioningPanel$.perform(VersioningPanel.java:389)
        at org.netbeans.modules.subversion.client.SvnProgressSupport.performIntern(SvnProgressSupport.java:103)
        at org.netbeans.modules.subversion.client.SvnProgressSupport.run(SvnProgressSupport.java:96)
Comment 1 benbrand 2008-11-16 09:19:42 UTC
Created attachment 73792 [details]
stacktrace
Comment 2 Tomas Stupka 2008-11-19 17:40:04 UTC

*** This issue has been marked as a duplicate of 122411 ***
Comment 3 Quality Engineering 2008-11-20 04:45:00 UTC
Integrated into 'main-golden', will be available in build *200811200201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/ef5ddb1b1bc0
User: Tomas Stupka <tstupka@netbeans.org>
Log: #153270 - NullPointerException at org.netbeans.modules.subversion.Subversion.getClient
more logging


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo