Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 153219 - NullPointer in DataView with aggregate function in sql and with database Intersystems Caché
NullPointer in DataView with aggregate function in sql and with database Inte...
Status: VERIFIED FIXED
Product: db
Classification: Unclassified
Component: SQL Editor
6.x
All All
: P2 (vote)
: 6.x
Assigned To: sansan
issues@db
65fixes1-verified
: REGRESSION
: 150950 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-14 13:02 UTC by sansan
Modified: 2009-02-19 20:37 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Patch (799 bytes, patch)
2008-11-15 16:28 UTC, sansan
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description sansan 2008-11-14 13:02:49 UTC
NullPointer in DataView with aggregate function in sql with the database Intersystems Caché.
I configure the JDCB Driver from Intersystems database Cachße 2007.1, after executing an
sql statement with an aggreate function: "SELECT COUNT(*) FROM Cinema.Film" the DataViewTablePanel get an 
NullPointer exception. As far as i see the reason is an NullPointer in DBColumn (75) because the 
table is NULL. I looks like that the ResulSetMetaData.getTableName() is also NULL.
Comment 1 David Vancouvering 2008-11-14 17:20:03 UTC
This sounds a lot like the bug andrei from the deva alias was going to fix.  sansan, are you "andrei?"  If so, I'll
assign this bug to you.
Comment 2 sansan 2008-11-14 18:45:17 UTC
No, sansan is not andrei ;) sansan = Andreas Schneider ( from dev@db.netbeans.org mailing list )

To make the issue more clear:
I see this NPE only with the JDBC Driver for InterSystems database Caché! Aggregate functions with MS SQL Server
works well.
Comment 3 David Vancouvering 2008-11-14 19:16:15 UTC
Sorry, Andreas, I do that with names, it's a real weakness.  Assigning to you, look forward to the patch.
Comment 4 sansan 2008-11-15 16:28:29 UTC
Created attachment 73785 [details]
Patch
Comment 5 John Baker 2008-11-18 22:27:29 UTC
fix looks fine to me.

I say go ahead and commit the fix.

sansan, were you planning on integrating the fix ?
Comment 6 David Vancouvering 2008-11-18 23:20:35 UTC
Sorry, I missed the patch being submitted!  Yes, I agree, looks good.

Andreas (sansan) can't integrate the patch, he doesn't have commit rights.

John, do you want to go ahead and integrate it?

Thanks, Andreas!  You may have fixed another bug for us too! :)
Comment 7 John Baker 2008-11-19 00:55:45 UTC
integrated fix by sansan
6fd32374d69f
Comment 8 nleck 2008-11-19 00:59:56 UTC
will this be in a daily build ? 
Comment 9 John Baker 2008-11-19 01:11:35 UTC

This will be available in daily builds but probably not until Fri.

I can send you a jar file if you want to try it out, but this is not an official release
Comment 10 nleck 2008-11-19 01:16:23 UTC
yes, if you could send me a jar I'll test it and see if that fixes the Sybase issue also. 
Comment 11 John Baker 2008-11-19 07:24:34 UTC
I verified that this also fixes the NullPointerException when using the Merlia driver with MS SQLServer
Comment 12 Quality Engineering 2008-11-19 16:44:20 UTC
Integrated into 'main-golden', will be available in build *200811191401* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/6fd32374d69f
User: John Baker <jbaker@netbeans.org>
Log: #153219 commit fix by user sansan
Comment 13 Roman Mostyka 2008-11-20 13:07:58 UTC
Verified according to comments.
Comment 14 John Baker 2008-11-21 21:36:45 UTC
*** Issue 150950 has been marked as a duplicate of this issue. ***
Comment 15 John Baker 2008-11-23 17:21:07 UTC
Should have been a P2 and also should be included in the 6.5 patch since this is probably a regression from 6.1
Comment 16 John Baker 2008-11-24 23:02:26 UTC
*** Issue 142612 has been marked as a duplicate of this issue. ***
Comment 17 pgebauer 2008-11-25 13:29:31 UTC
The fix has been ported into the release65_fixes repository.

http://hg.netbeans.org/release65_fixes/rev/8e74ed93031b
Comment 18 nleck 2008-12-11 23:03:18 UTC
We get this issue on Sybase also so it's not just "Intersystems Caché"


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo