Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 153160 - SQL History: Dialog shouldn't be modal
SQL History: Dialog shouldn't be modal
Status: VERIFIED FIXED
Product: db
Classification: Unclassified
Component: SQL Editor
6.x
All All
: P3 with 1 vote (vote)
: 6.x
Assigned To: John Baker
issues@db
65fixes2-verified
:
: 153222 (view as bug list)
Depends on: 152828 153632
Blocks: 152774
  Show dependency treegraph
 
Reported: 2008-11-13 16:09 UTC by Roman Mostyka
Modified: 2009-05-25 20:55 UTC (History)
2 users (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Roman Mostyka 2008-11-13 16:09:45 UTC
1. Execute some statement.
2. Open "SQL History" dialog and insert some statement.
3. Try to change statement in SQL editor without closing "SQL History" dialog.

Result: It is impossible since "SQL History" dialog is modal.
Customers compliant about this.
Comment 1 John Baker 2008-11-13 16:57:00 UTC
This isn't defect, it's a modal dialog by design
Comment 2 John Baker 2008-11-14 15:11:20 UTC
*** Issue 153222 has been marked as a duplicate of this issue. ***
Comment 3 John Baker 2008-11-14 15:20:08 UTC
I think this is a feature not a defect or enhancement because this is a significant change and requires HIE input
Comment 4 sansan 2008-11-14 15:33:27 UTC
To improve the user experience it was much better if the SQL History window was not an modal dialog.
For example:
If this was an TopComponent i can place it everywhere i want. I am able to insert some statements
in two or more SQL editor componentes without loosing my selection. 
Comment 5 John Baker 2008-11-14 15:40:13 UTC
to vote for this issue, click "Vote for this issue"
Comment 6 David Vancouvering 2008-11-14 17:26:33 UTC
+1, I agree with sansan, these are very good reasons for making it modal.  Only being able to insert one at a time and
having to close and re-open the window is a real pain.

I'd like us to consider if we can do this in this release.  I'll go ahead and add my vote :)
Comment 7 John Baker 2008-11-20 22:45:06 UTC
Not to be considered as a task and may not get to for 7.0 unless there are more votes or priority is raised
Comment 8 John Baker 2008-11-20 23:23:29 UTC
For now, I'll just make the dialog non-modal.

I'd like to hear feedback, thanks

746af5efd11d

If this is not what we want then please reopen
Comment 9 David Vancouvering 2008-11-20 23:54:46 UTC
It's a start, but I think what we really want is to make this a dockable window - I guess that's what "TopComponent" is.
 I suggest we discuss this at our next UI meeting with Mike.
Comment 10 Roman Mostyka 2008-11-21 11:20:33 UTC
Verified.
I filed an issue #153633 for the task to make "SQL History" dialog a dockable window. It can be closed after decision
not to make this dialog a dockable window.
Comment 11 Quality Engineering 2008-11-22 04:46:44 UTC
Integrated into 'main-golden', will be available in build *200811220201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/746af5efd11d
User: John Baker <jbaker@netbeans.org>
Log: #153160 SQL History: Dialog shouldn't be modal
Comment 12 pgebauer 2008-11-24 16:54:49 UTC
Since this issue is P3 priority, in accord with rules "How to include issues into patch" (http://wiki.netbeans.org/NetBeansPatches) it must include an 
explanation as to why its backport is necessary and how safe it is. Could you please provide such explanation? 

Besides, this is an ENHANCEMENT maybe a FEATURE (based on JBaker's comment: "I think this is a feature not a defect or enhancement because this is a 
significant change and requires HIE input"). Neither enhancements nor features are intended to be in patches. Please, explain why this one should be 
included into the 65patch1 (or remove the status whiteboard).

Comment 13 John Baker 2008-11-25 01:09:50 UTC
sansan, is it important to include this in the 6.5 patch or can the fix wait until 7.0 ?
Comment 14 Roman Mostyka 2008-11-25 17:18:00 UTC
If this fix is included into the Patch 1, then fix for the issue #153632 also should be included. The fix for the issue
#153632 is verified and both fixes should be in one patch.
Comment 15 pgebauer 2008-11-27 16:49:01 UTC
The required justification wasn't specified by 65patch1 code freeze. . The issue has been moved to 65patch2.
Comment 16 pgebauer 2009-01-12 12:10:29 UTC
The fix has been ported into the release65_fixes repository.

http://hg.netbeans.org/release65_fixes/rev/642fb6222ad4


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo