Bug 153072 - SVN files with "unknown" status
SVN files with "unknown" status
Status: RESOLVED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Subversion
7.0.1
Macintosh All
: P3 with 1 vote (vote)
: 7.1
Assigned To: issues@versioncontrol
issues@versioncontrol
:
: 198189 199028 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-12 20:39 UTC by _ gtzabari
Modified: 2012-07-16 20:30 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
messages.log (37.46 KB, text/plain)
2008-11-13 17:40 UTC, _ gtzabari
Details
screenshot showing netbeans and osx details (389.48 KB, image/png)
2010-10-17 18:59 UTC, cockney
Details

Note You need to log in before you can comment on or make changes to this bug.
Description _ gtzabari 2008-11-12 20:39:41 UTC
dev build 200811110201

The Subversion tab detect some files as having a status of "unknown" while others are detected fine. According to
TortoiseSVN those same files are perfectly normal, already committed and up-to-date. If I issue a SVN commit from within
Netbeans it tries committing those files a second time.

messages.log didn't contain any warnings/errors. Deleting /var/cache made the problem go away. I've got a backup of the
cache directory but it is 54MB. Please let me know how you want to debug this further.
Comment 1 Tomas Stupka 2008-11-13 13:43:09 UTC
- did the status appear after you refreshed or opened the versioning view or was the view already open and the status
changed after some action? Are you able to reproduce? did this happen more then once?

- do you remember which files had the status? their absolute path is stored in the caches .bin files so you could get
the interesting files from the cache by either searching for their name occurrence or just compute the cache files name
like the following:

String name = Integer.toString((new File("the files absolute path")).getParentFile().getAbsolutePath().hashCode() % 173
+ 172) + ".bin"; 

- please attach also the messages.log file

thanks
Comment 2 _ gtzabari 2008-11-13 17:16:58 UTC
1) I can reproduce the problem 100% of the time since I backed up the cache directory.

2) The Versioning tab is visible on startup and it has a valid status for these files. Then a few ms later it says
something along the lines of "communicating with server" and updates the status changes to "unknown" for all these files.

3) I didn't understand your discussion on calculating the cache filenames, especially given the fact that you didn't
mention which sub-directories to look in. Am I supposed to calculate the hash, look in svncache/<filename>.bin or
something? As far as I can tell those files simply contain a single filename. Please elaborate on what I should be doing.

4) It turns out that if I compress the cache directory using RAR I can bring it down to 11MB. If you're interested, you
could download that at http://bbs.darktech.org/netbeans.cache.rar -- please let me know when you're done so I can remove
the file from the server.
Comment 3 _ gtzabari 2008-11-13 17:37:29 UTC
I forgot to mention, one of the "unknown" files is "/trunk/adcaster/server/source/adcaster/domain/Administrator.java" so
you should be able to find it in the cache.
Comment 4 _ gtzabari 2008-11-13 17:40:24 UTC
Created attachment 73740 [details]
messages.log
Comment 5 Tomas Stupka 2008-11-13 19:36:42 UTC
> I didn't understand your discussion on calculating the cache filenames, 
> especially given the fact that you didn't mention which sub-directories to look in. Am I supposed to calculate the 
> hash, look in svncache/<filename>.bin or something?
yes. i thought we are talking about var/cache/svncache instead of var/cache. However, you managed to provide the whole
cache so this problem should be gone.

> 2) The Versioning tab is visible on startup and it has a valid status for these files. Then a few ms later it says
> something along the lines of "communicating with server" and updates the status changes to "unknown" for all these 
> files.
looks like the remote status returned by the repo confused the svn module somehow. could you please run 

svn status -u --xml Administrator.java

from the command line and attach the output 

thanks


Comment 6 _ gtzabari 2008-11-13 19:44:44 UTC
I happen to have moved some files around so I thought this would change the output, but it seems it does not for some
reason. For example, /trunk/adcaster/server/source/adcaster/domain/Administrator.java now resides in
/trunk/adcaster/server/source/adcaster/server/domain/Administrator.java yet:

1) Netbeans still reports the status as "unknown" in the old location if I use the old cache directory
2) The output of "svn status -u --xml Administrator.java" remains the same regardless of what directory I invoke it from:

<?xml version="1.0"?>
<status>
<target
   path="Administrator.java">
<against
   revision="16"/>
</target>
</status>
Comment 7 Tomas Stupka 2008-11-13 20:48:42 UTC
do i understand right - do you get the problem only when working with the old cache?

what exactly is the history of the problematic file? you were moving it around - what exactly were you doing? it would
be great if you could provide a scenario how to reproduce the problem...




Comment 8 Tomas Stupka 2008-11-13 20:49:49 UTC
by the way - did you move the files in netbeans or externally with some other tool?
Comment 9 Tomas Stupka 2008-11-13 20:56:34 UTC
one more thing

> 2. The Versioning tab is visible on startup and it has a valid status for these files
this confuses me a bit - in the original post you mentioned that the file was uptodate. So what was the status shown in
the view?
Comment 10 _ gtzabari 2008-11-13 21:05:44 UTC
I had a cache that was up-to-date. I don't recall if these problems started before I renamed the packages or after, but
I suspect before. I used the refactoring module to rename packages.

> this confuses me a bit - in the original post you mentioned that the file was uptodate. So what was the status shown in
> the view?

Good point. If I remember correctly, the view showed the files as modified, then it contacted the server and changed
their status to unknown. According to TortoiseSVN the files were unmodified.

There is one other thing worth mentioning: while I moved files around from within Netbeans I almost always commit SVN
from outside using TortoiseSVN. Is it possible that this corrupted the cache somehow? If I recall correctly, TortoiseSVN
supports true file renames/moves whereas Netbeans uses SVN delete followed by add. That's part of the reason I use
TortoiseSVN. Another part of it is that I sometimes wish to commit files that don't show up in the project (that is,
files outside the source/test directories).
Comment 11 Tomas Stupka 2008-11-14 09:50:19 UTC
> the view showed the files as modified, then it contacted the server and changed
> their status to unknown. According to TortoiseSVN the files were unmodified.
in what mode is the view set? all | local | remote? do you get "unknown" also when "local" is selected?

> while I moved files around from within Netbeans I almost always commit SVN
> from outside using TortoiseSVN. Is it possible that this corrupted the cache somehow?
yes. that could be the case ...

i've tried a couple of scenarios, thing like - move a file between folders (localy or remotely) and commit (from or
outside of IDE), etc., yet i wasn't able to reproduce

> Another part of it is that I sometimes wish to commit files that don't show up in the project (that is,
> files outside the source/test directories).
just a note - you might use the favorites view for this
Comment 12 Tomas Stupka 2010-09-28 12:45:43 UTC
wasn't able to reproduce and haven't been reported by anybody else. will close for now...
Comment 13 cockney 2010-10-17 18:59:12 UTC
Created attachment 102441 [details]
screenshot showing netbeans and osx details
Comment 14 cockney 2010-10-17 19:00:02 UTC
I'm having this issue at the moment using netbeans 6.7.1 on osx.  Screenshot attached.
Comment 15 Ondrej Vrabec 2010-10-18 09:56:50 UTC
Please reopen if reproducible with the current release, 6.7.1 is quite old.
Comment 16 davotoula 2011-07-25 16:22:10 UTC
OsX Netbeans 7rc1

I get an uknown SVN status when I:

1. create a new file
2. Rename the file but only change capitalisation (eg UserDAO to UserDao).

When I try and commit UserDao has two entries in the commit dialog.

From then on I have one UserDao always present with status unknown.

Work around: delete var/cache/svnache
Comment 17 kalali 2011-08-23 12:59:40 UTC
Just to update the bug status, I see the bug in NetBeans 7.0.1 on OSX Lion.
Comment 18 Ondrej Vrabec 2011-08-30 10:18:20 UTC
*** Bug 198189 has been marked as a duplicate of this bug. ***
Comment 19 Ondrej Vrabec 2011-09-19 12:21:47 UTC
fix: http://hg.netbeans.org/core-main/rev/86502132f374
Comment 20 Quality Engineering 2011-09-21 08:04:36 UTC
Integrated into 'main-golden'
Changeset: http://hg.netbeans.org/main-golden/rev/86502132f374
User: Ondrej Vrabec <ovrabec@netbeans.org>
Log: #153072 - SVN files with "unknown" status
Comment 21 Ondrej Vrabec 2011-10-06 10:31:03 UTC
*** Bug 199028 has been marked as a duplicate of this bug. ***
Comment 22 Meggy 2011-11-28 11:44:41 UTC
Bug still existing in NetBeans IDE 7.0.1 (Build 201111061500) on Mac OS X Version 10.7.2
Comment 23 Ondrej Vrabec 2011-11-28 12:23:28 UTC
> Bug still existing in NetBeans IDE 7.0.1 (Build 201111061500) on Mac OS X
> Version 10.7.2
as you can see, Target Milestone is set to 7.1. That means this issue is/will be fixed in 7.1 release not sooner.
Closing again.
Comment 24 aliveonearth 2012-01-21 07:19:13 UTC
Guide to workaround as this caused me some drama on 7.01 on Mac OS Lion 
worked for me.

Step 1
Check out a fresh working copy you know is good ( not required but recommended)

Step 2 
Open up Net beans and verify it reports files in unknown state, with blue locally modified icon over the offending directory ( see screen shot attached to bug )

Step 3 
Close net beans

Step 4 
rm $HOME/netbeans/7.0/var/cache/svncache/*
( note version number was 7.0 for 7.0.1  ?? )

Step 5
Start up Netbeans and the problem is gone.
you check out is good and you were not losing you mind thinking it wasn't.
Comment 25 aliveonearth 2012-01-21 07:22:39 UTC
Step 4 
rm $HOME/.netbeans/7.0/var/cache/svncache/*
( note version number was 7.0 for 7.0.1  ?? )
Comment 26 case 2012-07-16 20:30:31 UTC
This solved it for me too.

Step 4 
rm $HOME/.netbeans/7.0/var/cache/svncache/*
( note version number was 7.0 for 7.0.1  [CONFIRMED] )


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo