Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 152950 - NullPointerException at org.netbeans.modules.vmd.midp.propertyeditors.PropertyEditorComboBoxNoUserCode.getAsText
NullPointerException at org.netbeans.modules.vmd.midp.propertyeditors.Propert...
Status: VERIFIED FIXED
Product: javame
Classification: Unclassified
Component: Visual Designer
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Karol Harezlak
issues@mobility
http://statistics.netbeans.org/except...
EXCEPTIONS_REPORT, 65fixes2-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-11 13:07 UTC by Ivan Sidorkin
Modified: 2009-02-19 22:45 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
stacktrace (3.51 KB, text/plain)
2008-11-11 13:08 UTC, Ivan Sidorkin
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ivan Sidorkin 2008-11-11 13:07:29 UTC
Build: NetBeans IDE Dev (Build 200811110201)
VM: Java HotSpot(TM) Client VM, 10.0-b19, Java(TM) SE Runtime Environment, 1.6.0_04-b12
OS: Windows XP, 5.1, x86

Stacktrace: 
java.lang.NullPointerException
        at org.netbeans.modules.vmd.midp.propertyeditors.PropertyEditorComboBoxNoUserCode.getAsText(PropertyEditorComboBoxNoUserCode.java:130)
        at org.openide.explorer.propertysheet.RendererFactory$StringRenderer.reset(RendererFactory.java:967)
        at org.openide.explorer.propertysheet.RendererFactory$StringRenderer.connect(RendererFactory.java:931)
        at org.openide.explorer.propertysheet.RendererFactory.prepareString(RendererFactory.java:372)
        at org.openide.explorer.propertysheet.RendererFactory.getRenderer(RendererFactory.java:235)
        at org.openide.explorer.propertysheet.SheetCellRenderer.getTableCellRendererComponent(SheetCellRenderer.java:153)
Comment 1 Ivan Sidorkin 2008-11-11 13:08:29 UTC
Created attachment 73626 [details]
stacktrace
Comment 2 Ivan Sidorkin 2008-11-11 14:30:53 UTC
steps to reproduce:
- create new Mobile Application
- from navigator add Font Resource
- from navigator open font properties
- close properties dialog
- close HelloMIDet.java and discard changes
- open HelloMIDet.java

NPE
Comment 3 Karol Harezlak 2008-11-25 16:09:45 UTC
This problem is even deeper then I tough. It looks like some static non-final fields can be assign to the null
references and then problem is propagated to all Property Editors which use this value. Most likely this problem exists
in final release of 6.5. It is candidate for PATCH_2 for 6.5


change set:

http://hg.netbeans.org/main?cmd=changeset;node=0f67f616124b
Comment 4 Ivan Sidorkin 2008-12-16 08:52:01 UTC
verified
Comment 5 jinb 2009-01-08 14:02:26 UTC
fix backported into release65_fixes branch
http://hg.netbeans.org/release65_fixes/rev/1249f3662c14
Comment 6 Andrei Chistiakov 2009-01-19 12:06:03 UTC
Fix is verified with 65patch2 on WinXP.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo