Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 152354 - Freezes when trying to import a library
Freezes when trying to import a library
Status: VERIFIED FIXED
Product: versioncontrol
Classification: Unclassified
Component: Subversion
6.x
PC Windows Vista
: P2 (vote)
: TBD
Assigned To: issues@versioncontrol
issues@versioncontrol
65fixes2-verified
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-04 19:44 UTC by jirka_x1
Modified: 2009-01-29 15:22 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
:


Attachments
Thread Dump (22.71 KB, text/plain)
2008-11-05 14:25 UTC, jirka_x1
Details
messages.log file (46.23 KB, text/plain)
2008-11-19 12:17 UTC, matusdekanek
Details
stack/thread dump (27.87 KB, text/plain)
2008-11-19 14:45 UTC, matusdekanek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description jirka_x1 2008-11-04 19:44:56 UTC
This does not happen on a fresh project. However on several of our web projects (imported with an existing sources,
using shared libraries), the following sequence hangs the project:
1) Project properties > Libraries
2) click Add Library
3) click Import
4) select a library, say Absolute Layout
5) click Import library, the Import library window closes but the IDE hangs

The IDE hangs. I can move the "Add Library" window and it redraws, but the IDE is frozen. The folder "absolutelayout"
was created but nothing else.

(Also happens on Windows XP)
Comment 1 jirka_x1 2008-11-04 20:17:55 UTC
Removing all .svn directories from the project seems to help. Also deleting the whole content of the src folder helps.
Not that either of them is a possible work around. 
Comment 2 Peter Pis 2008-11-04 21:25:36 UTC
Could you please attach thread dump?

http://wiki.netbeans.org/GenerateThreadDump
Comment 3 jirka_x1 2008-11-05 14:25:01 UTC
Created attachment 73303 [details]
Thread Dump
Comment 4 jirka_x1 2008-11-06 22:34:34 UTC
Following http://wiki.netbeans.org/BugPriorityGuidelines, I am setting priority to P1. Not sure if I understand the
reproducibility correctly. If it happens for a project, it happens always for that project. But it does not happen for
every projects.
Comment 5 Peter Pis 2008-11-09 22:13:13 UTC
Subversion is somehow involved. P2. Could you please provide further information. What kind of project is that? ()j2e,
web ...), please also attach messages.log
Comment 6 jirka_x1 2008-11-10 04:36:08 UTC
it is a web project, with existing sources created in jdeveloper, the shared library folder is under WEB-INF. 

I will attach message log tomorrow, when I get to that particular machine (I assume you want the message.log created at
the same time as the thread dump).

Is there any workaround? 
Comment 7 Peter Pis 2008-11-10 08:44:08 UTC
Yes, the messages.log in which you've run into the issue.
Comment 8 Peter Pis 2008-11-10 09:08:21 UTC
I've just tried the latest build of NB 6.5 for web project (standard and with existing sources) and I can't reproduce
it. Any further details you could provide? Any chance to get your project?

Comment 9 Peter Pis 2008-11-10 11:11:00 UTC
Further questions:
1. If the problem occurs, does the IDE hang or it finishes in reasonable time?
2. If the problem occurs, could you please do and attach more thread dumps?
Comment 10 Tomas Stupka 2008-11-10 14:04:37 UTC
a) could reproduce with 6.5
- the shared lib folder has to be web-inf
- create webapp
- add library -> import -> ...

b) couldn't reproduce with a trunk build

possible workaround would be to deactivate the svn module for the time when setting up the libraries - main menu > tools
> plugins > installed > ...



Comment 11 Peter Pis 2008-11-10 15:43:02 UTC
To put libraries into WEB-INF is corner case and workaround exists. P2. Fix should be integrated into 65 PATCH1.
Comment 12 jirka_x1 2008-11-10 18:56:58 UTC
It looks like you can reproduce it. Do you still want me to provide any further information?

So it looks if we move the shared lib folder out of web-inf we should be fine.
Comment 13 Tomas Stupka 2008-11-10 22:36:33 UTC
> It looks like you can reproduce it. Do you still want me to provide any further information?
thanks. we are fine for now.
Comment 14 Tomas Stupka 2008-11-12 13:29:25 UTC
fixed in trunk

changeset:   107778:42ba13d42061
tag:         tip
user:        Tomas Stupka <tstupka@netbeans.org>
date:        Wed Nov 12 14:27:31 2008 +0100
summary:     #152354 - Freezes when trying to import a library
Comment 15 rbalada 2008-11-14 10:11:15 UTC
Please verify this issue so it can be included in NetBeans 6.5 Patch1
Comment 16 matusdekanek 2008-11-19 12:16:33 UTC
Unfortunatelly trunk build (18.11) still does not work (even with new subversion jar which fixed it in previous 
version). 
Reproduction (nothing changed):
create new web application
import project into svn repository 
trying to add a library into project freezes IDE (right when I press Finish button)

The same result was with new subversion jar, which seemed to fix this problem in previous versions, copied into modules 
folder.
Then IDE auto-updated itself (found update for subversion module: updated from 1.4.1 to 1.5...), but the result 
remained the same.
I will also add messages.log.

Cannot mark this issue as verified, recommend to reopen.

sys info:
Product Version: NetBeans IDE Dev (Build 200811181401)
Java: 1.6.0_10; Java HotSpot(TM) Client VM 11.0-b15
System: Linux version 2.6.24-21-generic running on i386; UTF-8; en_US (nb)
Comment 17 matusdekanek 2008-11-19 12:17:39 UTC
Created attachment 73900 [details]
messages.log file
Comment 18 Tomas Stupka 2008-11-19 13:07:13 UTC
attach a threaddump please
Comment 19 matusdekanek 2008-11-19 14:45:44 UTC
Created attachment 73913 [details]
stack/thread dump
Comment 20 Tomas Stupka 2008-11-19 15:00:29 UTC
my fault. changes weren't pushed yet. just try again ...
Comment 21 Quality Engineering 2008-11-20 04:43:41 UTC
Integrated into 'main-golden', will be available in build *200811200201* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main/rev/42ba13d42061
User: Tomas Stupka <tstupka@netbeans.org>
Log: #152354 - Freezes when trying to import a library
Comment 22 pgebauer 2008-11-24 09:31:14 UTC
The issue didn't pass the nomination process by nomination cut-off date. It has been marked as 65fixes2-candidate.
Comment 23 Peter Pis 2009-01-07 12:55:00 UTC
Verified in trunk.
Comment 24 rbalada 2009-01-13 14:57:15 UTC
The changeset http://hg.netbeans.org/main/rev/42ba13d42061 has been transplanted into release65_fixes repository as
http://hg.netbeans.org/release65_fixes/rev/0306b31db87b
Comment 25 Peter Pis 2009-01-16 10:46:20 UTC
Verified.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo