Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 152183 - [65cat] Assertions not processed
[65cat] Assertions not processed
Status: RESOLVED WORKSFORME
Product: java
Classification: Unclassified
Component: Project
6.x
PC Windows XP
: P3 (vote)
: 7.2
Assigned To: Tomas Zezula
issues@java
:
Depends on: 46298
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-03 10:57 UTC by ulfzibis
Modified: 2012-06-07 09:18 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
Assertions not processed (69.15 KB, image/jpeg)
2008-11-03 10:58 UTC, ulfzibis
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ulfzibis 2008-11-03 10:57:28 UTC
[ BUILD # : RC1 ]
[ JDK VERSION : 1.6.0 ]

I have run.jvmargs=-ea, but assertions are not executed.
See attachment ...
Comment 1 ulfzibis 2008-11-03 10:58:17 UTC
Created attachment 73113 [details]
Assertions not processed
Comment 3 Stanislav Aubrecht 2009-02-05 11:06:39 UTC
reassigning to java team for evaluation
Comment 4 Jan Jancura 2009-02-18 14:26:37 UTC
Works for me on Java Application Project. What is your project type? Do you execute it from command line or IDE?
Can you attach some how to reproduce?
Thanks.
Comment 5 Jan Jancura 2009-02-18 14:31:08 UTC
Can you try to add -ea to your Project/Properties/Run/VM Options?
Comment 6 ulfzibis 2009-02-19 12:21:11 UTC
Hi jjancura,

I don't understand the reason for your question.

I have written, that I have run.jvmargs=-ea. This will implicit:
- I execute from IDE (there is no run.jvmargs option for java commandline execution)
- I still have added -ea

Having a look to my attachment, and also to the given link will additionally twice answer your questions.

Have you really executed my reproducible example project from the given link ?

Comment 7 ulfzibis 2009-07-15 08:51:01 UTC
Statement assert is basic JLS construct, it should work -> P2

This issue likely depends on Issue 46298, 122677
Comment 8 Jiri Prox 2009-07-15 11:56:04 UTC
I can reproduce it with provided project, but not with fresh J2se project
Comment 9 David Strupl 2009-07-22 09:25:16 UTC
Not able to reproduce with normal project --> P3.
Comment 10 ulfzibis 2009-07-24 07:57:56 UTC
This issue is likely reproducible with every project which runs on supplemental/external Java platform.
Not having assertion check on external Java platform while running tests IMHO is big regression.
Comment 11 Tomas Zezula 2012-06-07 09:18:45 UTC
Works fine in dev (NB 7.2).
Hard to say when it was actually fixed, the JavaRunner was changed, testing in build-impl.xsl was several time changed.


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo