Bug 152104 - [65cat] Netbeans Hangs With Ctrl+Click on Python Code
[65cat] Netbeans Hangs With Ctrl+Click on Python Code
Status: VERIFIED FIXED
Product: python
Classification: Unclassified
Component: Editor
6.x
PC Windows Vista
: P1 (vote)
: 6.x
Assigned To: Torbjorn Norbye
nbpythonqa
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-11-01 20:31 UTC by sunbiz
Modified: 2009-01-15 01:58 UTC (History)
0 users

See Also:
Issue Type: DEFECT
:


Attachments
thread dump (17.75 KB, text/plain)
2008-11-01 20:31 UTC, sunbiz
Details

Note You need to log in before you can comment on or make changes to this bug.
Description sunbiz 2008-11-01 20:31:09 UTC
[ BUILD # : 200810312121 ]
[ JDK VERSION : other ]

Steps to reproduce:
1.) Create a new python project with python executable
2.) Right-click on source and Insert Code -> Property
3.) Leave the property field blank
4.) A method: __init__(self) is created
5.) Ctrl+click on __init__ hangs the IDE for close to 30 secs

Check the attached threaddump
Comment 1 sunbiz 2008-11-01 20:31:55 UTC
Created attachment 73053 [details]
thread dump
Comment 2 Torbjorn Norbye 2008-11-02 08:11:00 UTC
Fixed in changeset c0018bda3031. The problem was there was a bug such that constructors functions weren't marked as constructors in the index, and, 
there are thousands of instances of functions named "__init__", so when it was trying to find a valid declaration location, it was iterating through each one of 
these, parsing the corresponding file to try to find the given function - and failing every time since the element types didn't match.
Comment 3 Peter Lam 2008-11-04 18:20:00 UTC
verified in build 146 (2008110404162)


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2012, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo