Bug 151903 - Connect where authentication fails comes brings up multiple dialogs
Connect where authentication fails comes brings up multiple dialogs
Status: RESOLVED FIXED
Product: db
Classification: Unclassified
Component: Code
6.x
All All
: P3 (vote)
: 6.x
Assigned To: Jiri Skrivanek
issues@db
:
: 151178 151497 (view as bug list)
Depends on:
Blocks: 152766
  Show dependency treegraph
 
Reported: 2008-10-30 20:56 UTC by David Vancouvering
Modified: 2009-07-10 08:01 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments
Sample project that exhibits the JComboBox bug (108.61 KB, application/x-compressed)
2008-11-03 17:29 UTC, Rob Englander
Details

Note You need to log in before you can comment on or make changes to this bug.
Description David Vancouvering 2008-10-30 20:56:27 UTC
- Create a connection to a MySQL server as root
- Disconnect
- Open properties for connection
- Change user to 'foo'
- Reconnect
- You get an error saying connect fails, but you get it four or five times (OK, OK, OK, OK!)
Comment 1 Rob Englander 2008-11-03 17:29:41 UTC
Created attachment 73141 [details]
Sample project that exhibits the JComboBox bug
Comment 2 Rob Englander 2008-11-03 17:34:55 UTC
Sorry, the ComboBug.zip attachment doesn't belong to this issue.  
Comment 3 Jiri Rechtacek 2009-02-10 15:37:48 UTC
Reassigned to new owner.
Comment 4 Jiri Skrivanek 2009-06-30 13:26:54 UTC
Fixed.
core-main #3312f021732d

Comment 5 Quality Engineering 2009-07-01 05:30:15 UTC
Integrated into 'main-golden', will be available in build *200907010200* on http://bits.netbeans.org/dev/nightly/ (upload may still be in progress)
Changeset: http://hg.netbeans.org/main-golden/rev/3312f021732d
User: Jiri Skrivanek <jskrivanek@netbeans.org>
Log: #151903 - ExceptionListener must be added just once (DatabaseConnection.addExceptionListener is adding to Set, so duplicates are avoided).
Comment 6 Jiri Skrivanek 2009-07-01 08:36:17 UTC
*** Issue 151497 has been marked as a duplicate of this issue. ***
Comment 7 Jiri Skrivanek 2009-07-10 08:01:25 UTC
*** Issue 151178 has been marked as a duplicate of this issue. ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo