Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 151784 - [65cat] [core] Code Hints generate incorrect code for typist.
[65cat] [core] Code Hints generate incorrect code for typist.
Status: RESOLVED WORKSFORME
Product: editor
Classification: Unclassified
Component: Completion & Templates
6.x
PC Windows XP
: P2 (vote)
: 6.x
Assigned To: Dusan Balek
issues@editor
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-29 21:09 UTC by esmithbss
Modified: 2009-02-19 20:45 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description esmithbss 2008-10-29 21:09:22 UTC
[ BUILD # : RC-1 ]
[ JDK VERSION : 1.6.0_07 ]

When I am typing, if the code hint window pops up and I am typing
faster than the code hint window can lookup hints, the code that is
placed into my file is the code that is at the top of the hint window
and not the method I am selecting.

Typically this only happens on the first code hint during the editing
session.  Once the first code hint has come and gone, the background
load of any support information has been completed and lookups are
much faster.
Comment 1 Lukas Hasik 2008-10-29 21:27:11 UTC
what is code hint window? Do you mean code completion (example - http://blogs.sun.com/netbeansphp/resource/PHPDoc.png)
Comment 2 Dusan Balek 2008-10-30 09:30:43 UTC
Also, what type of source file are you editing - Java?
Comment 3 esmithbss 2008-11-02 06:00:20 UTC
Yes it is the code completion window.

It doesn't matter what type of file I'm editing.  The problem I encounter is happening with Ruby on Rails and Java files.

It appears that the first time I bring up the Code Completion window, if I type faster than the IDE can load the full
index for the code completion window, then the code completion window doesn't do any resolution on my keystrokes to
narrow the number of possible solutions so the first time I bring up the Code Completion window, regardless of what I'm
typing, the first item in the code completion window is what is put in my file.
Comment 4 Jiri Kovalsky 2008-11-04 21:16:37 UTC
Eric answered your questions thus removing INCOMPLETE keyword. Dusane, any other comments? Thanks!
Comment 5 Dusan Balek 2008-11-14 14:51:50 UTC
I have tried a couple of times to reproduce the described behavior in Java editor - however - without any success. Could
you please provide me with exact steps to reproduce (simple test file together with exact sequence of keystrokes that
leads to the wrong code completion)? Thanks.
Comment 6 Miloslav Metelka 2009-02-03 16:09:32 UTC
I'm also unable to reproduce, closing as worksforme. esmithbss do you press Enter at certain point when the completion
is opened?


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo