Please use the Apache issue tracking system for new NetBeans issues (https://issues.apache.org/jira/projects/NETBEANS0/issues) !!
Bug 151686 - Transactions on SQL command execution
Transactions on SQL command execution
Status: RESOLVED DUPLICATE of bug 31149
Product: db
Classification: Unclassified
Component: Code
6.x
PC Linux
: P3 (vote)
: TBD
Assigned To: Jiri Rechtacek
issues@db
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-10-29 10:21 UTC by kovica
Modified: 2013-03-17 22:32 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description kovica 2008-10-29 10:21:50 UTC
SQL commands are not run in a transaction, at least I didn't find any buttons that I could commit or rollback an SQL
command in SQL Command window.
This is the case for UPDATE / INSERT / DELETE statements. If I do a SELECT then I can change data in a resulting table
and commit/rollback changes there.

Running SQL statements in transaction from SQL Command window is needed.
Comment 1 Jiri Rechtacek 2009-10-16 14:13:48 UTC
Reassigned to new owner.
Comment 2 matthias42 2013-03-17 22:32:21 UTC

*** This bug has been marked as a duplicate of bug 31149 ***


By use of this website, you agree to the NetBeans Policies and Terms of Use. © 2014, Oracle Corporation and/or its affiliates. Sponsored by Oracle logo